What's new
Apple iPad Forum

Welcome to the Apple iPad Forum, your one stop source for all things iPad. Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Cydia and 8.1 jailbreak

b00bie

iPF Novice
Joined
Sep 4, 2010
Messages
216
Reaction score
8
Location
Montgomery, NY
I finally took the plunge and updated my iPad Air to 8.1 and applied the latest Pangu 1.2.0. Everything seemed to go smooth and I started to reload some of my updated tweaks, but several of the tweaks I tried to install displayed blank pages in Cydia. For example I wanted to install BytaFont 2 when I searched for it in Cydia it was found but when I clicked on the search link I got a blank page, I was able to return to the search page to continue to look for other tweaks but there seems to be a number of blank pages on various tweaks. Does this have to do with the repos not providing data to Cydia or did something in the Cydia installation that ran the first time I accessed it go wrong? Any suggestions would be appreciated.

Update:
It appears to be more of a problem than I first reported, I can no longer download anything from the App Store, when I select install the Pad crashes into safe mode and I have to reboot to get it back up. Should I just start over, reinstall 8.1 and rerun Pangu, just rerun Pangu or give up jailbreaking and try a new hobby?
 
Last edited:

Mickey330

Administrator
Staff member
Joined
Aug 30, 2010
Messages
11,892
Reaction score
2,225
Location
Western NY state (USA)
I haven't jailbroken my iPad Air yet, but I have jailbroken my brother's iPad3 (on iOS 8.1). I didn't get any of the issues you describe and I did a full restore of iOS 8.1 onto his iPad (using the DFU/shift method).

When I first went to Cydia, I had to go to the Changes tab and hit the "Refresh" button (at the upper left) in order for everything to be populated. Maybe try that?

Then, I had no issues with the AppStore. The main reason why we upgraded my brother's iPad was because he was tired of the inability to update apps. So, once we were done with the jailbreak, we opened the AppStore and it opened fine. I even installed some apps for him (so he could take advantage of the widgets available in the Notification Center).

All this to say: don't give up on jailbreaking. Maybe try a restart/reset of the iPad? Or, worst case, restore a fresh iOS 8.1 and re-jailbreak?

Marilyn
 
OP
b00bie

b00bie

iPF Novice
Joined
Sep 4, 2010
Messages
216
Reaction score
8
Location
Montgomery, NY
Thanks for your reply, I tried the refresh button on Cydia but no go, it's really strange most of the tweak pages are fine but some just contain no data. The iTunes problem turned out to be a tweak called password pilot when I removed it the store works fine. The giving up on the jailbreak was a poor attempt at humor on my part. Things seem stable for now. I really miss Auxo (a lot) and Springtomize and iKeywi
 

willerz2

iPF Novice
Joined
Feb 22, 2012
Messages
1,341
Reaction score
255
Location
New York
In the future if you're getting no data from the tweak pages, if you have access to a computer, try pinging the source of the tweak. Generally the larger repositories have mechanisms to reboot upon connectivity failure, but for other repos, you can just ping the actual repo link to see if your packets are being sent. If the tweak description page is containing no data and you have access to a computer that can SSH to your device. Log in as root, enter your SSH password, and run the command 'apt-get update', which essentially updates the caching of the packages like refresh, but ran as a raw command. It may or may not resolve the issue but I generally don't have any issues with running apt-get update when I have an issue with caching using Cydia
 
OP
b00bie

b00bie

iPF Novice
Joined
Sep 4, 2010
Messages
216
Reaction score
8
Location
Montgomery, NY
Thanks Willerz, the SSH stuff is a little beyond me, the really interesting thing about this is that if I go to a page that has no information and I select install not only does the tweak install but the information page becomes populated. I have to assume that the repo is connected???? Saurik just put out another installer update (16) while I was fooling around on Cydia, I installed it but it didn't resolve my issue. As long as I can work around it by installing the tweak to get the page updated it will do for now. With the exception of that one password tweak everything is working great, looking forward to some updates now.
 

willerz2

iPF Novice
Joined
Feb 22, 2012
Messages
1,341
Reaction score
255
Location
New York
It might be that the server has high latency in delivering the description page. It's prominent in slower network connections as the transfer may have timed out before you can cache it properly. Particularly since the iPhone 6 and 6+ has been introduced and accommodate a significant proportion of current devices, it may be that the connectivity is strained as it's forked much more now. But hey, as long as it works, there're no complaints here.
 

Most reactions

Latest posts

Top