What's new
Apple iPad Forum 🍎

Welcome to the Apple iPad Forum, your one stop source for all things iPad. Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Unable to buy any in-app purchases


iPF Noob
Dec 2, 2011
Reaction score
Hi there, when ever I try to buy an in-app purchase from any of my apps I go to the appropriate area of the game and try to view the various items available for purchase. I can see the items but the never have a purchase price - if I try to purchase something my iPad just sits in the "processing" mode for several minutes. I eventually have to double click out of the game. Sometime later I always get a "confirm"message asking if I want to make the purchase, I can be in any other app at the time. If I press cancel the purchase does not get processed, but if I press confirm the purchase is processed and I get an iTunes invoice but I do no get the purchase (gems for example). The last time this happened I emailed the developers concerned and they manually sent me my purchase (z2Live with Nanopods in Battle Nation). I have just tried to buy gems in Dragonvale - confirmed the purchase from within another app after having to get out of Dragonvale after several minutes of "processing" - but even an hour after the confirmation there is no sign of my gems. Any ideas??:(
Hi and welcome to the Forum!

Whenever an app plays up it is a good idea to close it completely, give this a try:
Do the four finger swipe up or double press the home button to reveal your multi task bar along the bottom. It will show all the apps that you have opened at one time or another. Long press one of these apps until they start to jiggle and red minus signs will appear above them all. Press all the minus signs, this will close them, not delete them. It's a good idea to do this regularly just to keep them all running smoothly, I do mine every night. Check and see if this has made a difference.

The IPad Forum is a community of members from all walks of life and from all over the world coming together to share our experiences and to help each other learn about this wonderful piece of technology the Ipad. There is a wealth of information already here in the many threads we have so doing some searches will answer most of the questions you have. If then you cannot find the answer you are seeking then by all means post your question. There are many friendly and informed members here only too willing to help you.

We also have our own App - It is a very simple app to navigate.
Reading the IPad manual is a great place to start so please download a copy of these.
A very informative thread from which you will learn many tips and shortcuts for the IPad.
We have rules like any Community so please read these also

Once again we welcome you here and are so pleased you have joined us!

Sent from my iPad using iPF
Thanks for the warm welcome!

I tried your suggestion of clearing out the bottom task bar, I even fully turned off the iPad, but no luck
- I still don't get a dollar amount listed within th in-app purchase screen. Last week I tried to correct it by deleting the app completely from my iPad and then reloading it, that didn't work either.

At least it saves me heaps of money !!! Thanks, Elle
You'll need to reset your iPad :
Reset: Hold the power off button and the home button simultaneously, keep holding them in and you will see the power off slide appear and disappear, wait until you see the Apple logo appear before releasing the buttons. It will take a little longer for your iPad to start. This is a reset.
I hope this solves it. Let us know.

Sent from my iPad using iPF
Hi there, I did the reset and it fixed the issue within the DragonVale app - but it didn't solve the problem within either Battle Nations or Trade Nations, both show blue hash signs instead of dollar values for each of the items available for purchase. In the Oregon Settler app I can't even get into the in-app purchase screen.

Very strange ! Thanks for trying to solve these issues, Elle
That's really strange, I've never played these games before but could it be a case of that you need to reach a certain level before being able to buy certain things? Maybe get in touch with the developer and ask if anyone else is having a problem here. It's in their best interest to help you too!
Good luck with this.

Sent from my iPad using iPF

Most reactions

Latest posts