What's new
Apple iPad Forum 🍎

Welcome to the Apple iPad Forum, your one stop source for all things iPad. Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

🌟 Exclusive 2024 Prime Day Deals! 🌟

Unlock unbeatable offers today. Shop here: https://amzn.to/3LohMKi 🎁

eMail problem

walterh1

iPF Noob
Joined
Apr 6, 2010
Messages
7
Reaction score
0
Location
Green Hills, PA
Just got the iPad this weekend. I have had an iPhone for several years. I am a PC user.

Just this weekend, the following email problem started on the iPhone, and is also occurring on the iPad. I get this error: "Cannot send mail - The sender address was invalid". I checked the settings in Mail, Contacts, Calendars in both devices. Other than this, both devices work OK.

I have no problem receiving email on the iPhone.
 
Just got the iPad this weekend. I have had an iPhone for several years. I am a PC user.

Just this weekend, the following email problem started on the iPhone, and is also occurring on the iPad. I get this error: "Cannot send mail - The sender address was invalid". I checked the settings in Mail, Contacts, Calendars in both devices. Other than this, both devices work OK.

I have no problem receiving email on the iPhone.

Walter,

This sounds like a problem with your SMTP host. Take a look at your outgoing mail server, who is it? What is the email address you are using to send mail as? Do they match?

If they don't, you may need to contact your ISP and ask them to allow the email address your using, or switch your SMTP hosts.

I need more details but I'm sure we can help you figure this out.
 
Same problem

I'm having the same problem. I've tried the recommendations from Apple Support with no change. Not sure what the next step should be. Any help is greatly appreciated. Kent
 
If the error just "started" happening, then yes, it's not the iPhone and iPad. As others said, check SMTT settings. If other devices on the same network can receive mail then look at their settings and compare ti the iPad.

The mail on the iPad/iPhone works just like mail on your desktop or lapto. Same settings.

Oh, and welcome! Next time you have a problem you should post in the iPad help forum here. This is the introduction and help for using the forums.....

Just to be sure you got it set up right:

On your iPad tap in the "settings" icon. Now tap on the mail and contacts tab. At the top you will see "accounts", tap on your email account. Around mid-page you will see the outgoing mail settings. It should say mail.yourprovidername.net . For example I am on Charter. So mine says mail.charter.net . (it will be .net or .com depending on your provider.

Incoming should have the same.
 
Last edited:
I managed to correct the problem. I'm not sure exactly what I did, but it was an SMTP problem; I had the wrong password.
 
Sending email on the pad/phone is a familiar problem. Often the issue is becasue of the outgoing mail settings/ port, user name/password, etc. I have a tutorial/walk through that shows how to properly configure the device here: configure multiple ipad email accounts %%title%% iPad tutorials and reveiws iPad equipment and software

I hope this helps, as I KNOW not being able to send email is frustrating. Also, if you have multiple accounts set them up carefully or you'll be sending all mail from one account.

Like I said follow the instructions above and you should be fine!

-John
 
Exact outgoing settings?

Hii all - I've read all the posts and tried everything but still cannot get outgoing email from my charter account to work (incoming email is fine). If yours is working would you mind posting the exact settings? Thanks.
 
As near as I can remember, I had to get my service provider to correct something at their end. The settings data I am currently using is as below: (user: [email protected] / the provider address: promail.ptd.net )

Accounts
Walter > (go to ‘Walter’ page)

Walter page
Account ON

Pop Account Info
Name Walter XXXXX
Address [email protected]
Description Walter

Incoming Mail Server
Host Name promail.ptd.net
User Name walterharry
Password *********

Outgoing Mail Server
SMTP promail.ptd.net > (go to SMTP page)

Advanced >


SMTP page
Primary Server
promail.ptd.net ON > (go to promail.ptd.net page)

Other SMTP Servers
(none used)

promail.ptd.net page
Server ON

Outgoing Mail Server
Host Name promail.ptd.net
User Name walterharry
Password *********
Use SSL OFF
Authentication password > (go to ‘Authentication’ page)
Server Port 25

Authentication page
MD5 Challenge-Response
NLTM
HTTP MD5 Digest
Password (should have check mark)
 
I am getting a message when I check email on my iPad. Just started a couple of days ago and I haunt changed anything, settings, etc. It says, an error occurred when this email was sent. The email looks fine and I can send and receive emails just fine. Does anyone else get this message?
 
Here it is again.
Cannot Sent Mail
An error occurred while delivering this message.

This is what I see each time I open my email. If I say OK it comes back and asks me a few more times than finally goes away.
 
This is my first use...if I'm in the wrong place, sorry:). Anyway, Ive had my Ipad since June and this week I started getting the unable to send message...it's apparently only one message, as all others are being received OK....how do I find which MSG is having the problem so I can delete it...the darn box is popping up all the time now, and my stmp seems fine...any thing I can look for...thank..Betty
 
email connect problem with Charter.net

I have a good solid wifi network connection with my iPad. But I cannot register my Charter.net mail account. Anyone having this type of problem?
 
My server is British Telecom who use Yahoo at present. I have the same problem.
Although I can send and receive mail with no problem via a 'Yahoo' app, I can't send via BT or Yahoo via the blue 'Mail' app, although I do receive it OK. Like others I always get the "wrong email address or password" message. I've tried to sort it but have now given up. But it is a pain because when I try to mail photos taken on the iPad they go via this route and sit unsent in my Out Box.
 
did you ever solve this problem? since the new BT email i can receive but not send email using the iPad email.
 

Most reactions

Latest posts

Back
Top