Restoring iPad 1?

Discussion in 'iPad Hacking' started by HUNTER1, Sep 7, 2014.

  1. HUNTER1

    HUNTER1
    Expand Collapse
    iPad Fan

    Joined:
    Jul 21, 2010
    Messages:
    223
    Thanks Received:
    9
    My iPad I is jailbroken 4.2.1. I believe the highest firmware for iPad 1 is 5.1.1, is it worth it to restore to 5.1.1, or just leave it where it is? thanks
     
  2. Mickey330

    Mickey330
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Aug 30, 2010
    Messages:
    11,892
    Thanks Received:
    2,225
    Personally, I'd upgrade it to iOS 5.1.1. You'll take advantage of the newer features offered by iOS 5.1.1.

    'Sides, iOS 5.1.1 is still jailbreakable on the iPad1. So, you can upgrade and jailbreak.

    IMNSHO, it's always best to be on the most current iOS [for a jailbreaker ... it's best to be on the most current JAILBREAKABLE iOS :) ).

    So, being on iOS 5.1.1 would fit the criteria, for me.

    Good luck with your decision.

    Marilyn
     
  3. scifan57

    scifan57
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Dec 3, 2011
    Messages:
    27,496
    Thanks Received:
    9,228
    Also, there are more apps available for devices on iOS 5.1.1 than for iOS 4.2.1.
     
  4. HUNTER1

    HUNTER1
    Expand Collapse
    iPad Fan

    Joined:
    Jul 21, 2010
    Messages:
    223
    Thanks Received:
    9
    Sounds good and yeah, I'm unable to download lots of apps because my firmware is way behind. I'll do the restore and thanks
     
  5. willerz2

    willerz2
    Expand Collapse
    iPad Addict

    Joined:
    Feb 22, 2012
    Messages:
    1,341
    Thanks Received:
    255
    For apps that have the pre-requisite of iOS 6.0 and above (does not apply for iOS 7.0 and above), if you must, there is a way to circumvent the pre-requisite and still install the app. Note that this is unstable and often not recommended because there may be API differences that the app is calling on, hence the iOS 6.0+ requirement. But for iOS 6.0+ apps, mostly it's a system requirement, not much so a software requirement, so even if you circumvent it, it will not cause harm to your device assuming it's an Apple AppStore official app (this cannot be said for Cydia packages as circumventing for packages should NEVER be done).

    But in essence, if you really need to use an iOS 6.0+ requiring application from the AppStore and is mandatory that you use it, then we can circumvent the pre-requisite (without resorting to piracy as many users will suggest on other sites/forums).

    On the note of iOS 7.0+ requiring apps, it's recommended that you do not circumvent them because if the app is requiring iOS 7.0+, it most likely does not use residual APIs from the <iOS 6 era, and installing such apps will most likely result in a boot loop, meaning you'd end up crashing often and probably boot looping, so you'd have to restore frequently, making it impractical.
     
  6. HUNTER1

    HUNTER1
    Expand Collapse
    iPad Fan

    Joined:
    Jul 21, 2010
    Messages:
    223
    Thanks Received:
    9
    I just restored to 5.1.1 and will not jailbreak at this time. I found that most apps from app store require ios7, although there are still few of the same apps that can be downloaded for lower firmware. I may need to upgrade my iPad just to catch up.
     

Share This Page