What's new
Apple iPad Forum

Welcome to the Apple iPad Forum, your one stop source for all things iPad. Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Ipad sound but no video when connected to TV

Ghostontheline

iPF Noob
Joined
Jun 17, 2010
Messages
3
Reaction score
0
Location
Templecombe,Somerset,England
Today I purchased the Apple Component AV Cable MB 128ZA/B from the Apple store in Bath, Somerset. I connected the 3 video and 2 sound leads to my Philips 42" TV and the docking cable to the Ipad. I then tried to watch a video the sound was perfect but no video appeared on my TV. I did the same with YouTube with the same results. I also have a Panosonic 26'" TV which is 6 years old, made the same connections and had the same results!!!.
Have I got the wrong cable, the guy in the Apple store seemed unsure if the Ipad would work with a TV? :confused:
 

Purpleorchid

iPF Novice
Joined
Jun 9, 2010
Messages
456
Reaction score
0
Location
Seattle
Are you plugging the red, green, and blue video plugs into the red, green and blue plugs at the tv? Those colours need to match up. You can't plug it into a red, white or yellow plug.

Also, did you select the correct input source on your tv? The on screen tv choices are typically, TV, AV1, AV2, HDMI, etc. Make sure you pick the one that matches what you plugged the cables into.

And absolutely, the iPad plays movies, photos and videos to the tv. I use a composite AV cable with mine. Your component cable should work too.
 
OP
G

Ghostontheline

iPF Noob
Joined
Jun 17, 2010
Messages
3
Reaction score
0
Location
Templecombe,Somerset,England
I have double checked that the plugs are connected into the correct sockets and that the correct input is selected, still sound only!. A message comes up on the TV screen No Video Input.
 

Purpleorchid

iPF Novice
Joined
Jun 9, 2010
Messages
456
Reaction score
0
Location
Seattle
Perhaps a faulty cable?

What were you trying to watch? Did you try other movies or do a slideshow of your photos?

There is no setting needed on the iPad either. Once connected and the tv input is selected, sound and video should work.

I'd say if even the photos aren't displaying, try exchanging the cable set for another one.
 
OP
G

Ghostontheline

iPF Noob
Joined
Jun 17, 2010
Messages
3
Reaction score
0
Location
Templecombe,Somerset,England
Just been down to the Apple store in Exeter, after trying several sets of cables we found one that worked. The problem with the Apple Component AV cable is that the connection to the plugs are weak, not much force required to break them. Anyway problem solved, thanks for your help guys.:D
 

dom123

iPF Noob
Joined
Jun 15, 2010
Messages
13
Reaction score
0
Location
ohio
my Apple AV cables do not work for iTunes movies, flixter app

it does work for netflix, YouTube, wired magazine and cNet.

I sent a question. to apple support, will post answer
 

Latest posts

Top