1. Due to the recent site upgrade, the iPadForums (iPF) App will no longer work. The new iPadForums.net website has been designed from the ground up to work perfectly from any mobile, tablet, or desktop computer using the built in internet browser. Create a shortcut to iPadForums.net on your home screen by following these steps: Create an icon for iPadForums.net

Trouble printing from ipad2 to Windows 7 printer

Discussion in 'iPAD Connect' started by bcross, Sep 3, 2012.

  1. bcross
    Offline

    bcross iPF Noob

    Joined:
    Sep 3, 2012
    Messages:
    1
    Thanks Received:
    0
    Trophy Points:
    0
    Location:
    Boston
    Ratings:
    +0 / 0
    Hello,
    I'm not sure if iPAD connect is the right discussion group, so please let me know if this should be elsewhere.


    I am unable to print from my ipad2 to a Windows 7 desktop usb printer. I realize that this may not be a supported configuration, but I have seen several sites purporting that this can be done.



    What I've done so far:
    Installed the Bonjour Service , and verified that it was allowed both publicly and privately in Windows Firewall.

    Installed the Airprint service manually, using the following command line: sc.exe create AirPrint binPath= "C:\Program Files (x86)\AirPrint\airprint.exe -s" depend= "Bonjour Service" start= auto

    I also added this service to Windows Firewall, public and private.


    The service started successfully (sc start AirPrint)
    I launched the Bonjour printer wizard and added two printers. I now see these printers when I open Devices and Printers. However, when I send a document to this printer (from my desktop), nothing actually prints, but shows with an ERROR status in the print properties. That's problem #1.



    Whenever I try to locate/install a printer from the ipad, none are found. This is problem #2.

    I have a wireless network, which I have verified that the ipad is connected to. The desktop had a wired connection to the wireless router. Does the desktop have to be wireless as well? There is only one subnet (192.168.1.x)
    I also disabled Windows Firewall, and was still unable to locate a printer, so I'm ready to rule the firewall out of the equation.



    Problem #3:
    I tried stopping the airprint service and running directly to see if there were any error messages. I received the following:

    C:\Program Files (x86)\Airprint>airprint.exe

    Listening for connections on 0.0.0.0:631...
    Listening for connections on [::1]:631...
    Unable to remove "C:\Users\Bert\AppData\Local\Temp\/cupslite/cupslite" - No such file or directory
    OKIB411: DeviceCapabilities(DC_ENUMRESOLUTIONS) failed
    Epson: DeviceCapabilities(DC_ENUMRESOLUTIONS) failed
    XpdfPrint library version = 3.02.33




    Is there anything else I can try, or another way to verify that the steps I've done have at least been successful?

    Thank you!

    Bert Cross
  2. Blue92
    Offline

    Blue92 iPad Fan

    Joined:
    Mar 4, 2012
    Messages:
    152
    Thanks Received:
    13
    Trophy Points:
    18
    Location:
    Central Ohio
    Ratings:
    +13 / 0
    I also tried installing the "AirPrint" and had no luck.

    Found and installed FingerPrint and haven't had a problem printing via wireless from either my iPhone or iPad since. :thumbs:

    They have a free trial version you can setup to make sure it meets your needs.

Share This Page

Search tags for this page
\temp/cupslite/cupslite” – no such file or directory
,
airprint window listening
,

cupslite

,

dc enumsolutions failed airprint

,
devicecapabilities(dc enumresolutions)
,

devicecapabilities(dc enumresolutions) failed

,
devicecapabilities failed
,
how to connect ipad w/ windows 7 printer
,
ipad print to windows 7 printer
,
ipad printing for windows 7
,

listening for connections on 0.0.0.0:631...

,
print from ipad 2 to windows printer
,

print from ipad to win 7

,
print from ipad to win7 printer
,
printing document from ipad2 using airprint and windows 7
,
printing from ipad to windows7
,
sc start airprint
,

windows 7 ipad printing