Contacts doubled?

Discussion in 'iPad OS' started by NYHorsewoman, Oct 15, 2011.

  1. NYHorsewoman
    Offline

    NYHorsewoman iPad Fan

    Joined:
    May 19, 2011
    Messages:
    282
    Thanks Received:
    6
    Trophy Points:
    0
    Ratings:
    +6 / 0
    So it seems that there are a few "group" options for contacts in the address book now. However, no matter what I do each card has a "2" in the bottom right corner. When I click it two of the same person come up, one under iPad and the other under "Unified" whatever that means. I can't figure out how to eliminate this issue. My contacts are not selected to back up to the cloud. I pull them from Google and originally pulled them from Outlook somehow when I first got the iPad but I don't remember how exactly I did that. In any case, it is not that big of a deal, but a little annoying. Anyone have ideas for fixing this?
  2. twerppoet
    Offline

    twerppoet iPad Legend

    Joined:
    Jan 8, 2011
    Messages:
    16,448
    Thanks Received:
    2,047
    Trophy Points:
    113
    Location:
    Walla Walla, WA
    Ratings:
    +2,352 / 1
    Tap on the red ribbon and see what's on the Groups page. I'm guessing you've got a local and gmail database.

    If you're Google contacts are up to date (visit your website and make sure), then you can go to your account settings for Google and turn off the Contacts. It should ask you if you want to delete them. Say yes. (don't worry, they're still on Google, remember).

    Visit the Contacts app to make sure you now have only the local database.

    Go back to settings and turn your Google Contacts back on. It should offer you the choice of Deleting or Merging with the local contacts. Choose Merge to be on the save side. Delete would probably work, and you can try that if you end up with a ton of duplicates and don't want to weed them out. Oops, you should get a Keep and Merge option. Choose Merge.

    If you choose Merge and get duplicates, don't forget that you can visit the Google Contact page on a desktop. It has a tool for finding and resolving duplicates.
    Last edited: Oct 15, 2011
  3. twerppoet
    Offline

    twerppoet iPad Legend

    Joined:
    Jan 8, 2011
    Messages:
    16,448
    Thanks Received:
    2,047
    Trophy Points:
    113
    Location:
    Walla Walla, WA
    Ratings:
    +2,352 / 1
    Oh yes, if you tap on Unified it shows you all the information from both contacts. The other option will show you the contact information from the entry you are not currently viewing. On the Group page you can choose to view the combined databases with All Contacts. If you do that the Unified option goes away and you can choose to view what is in each of the databases. Since your databases are probably almost identical, you'd see no difference.

    How did it happen?

    My guess is that at some point you deleted the Google account (or turned off Contacts) and chose to keep the data. This made it a local database. When you re-added the account you chose Keep, which meant keep what is already on the iPad and make a new database. So you ended up with a local iPad database and a new synced one.


    Oops, realized that means the Delete option never shows up when adding the account. My fault. I can't keep every thing straigh. That means you'll only get the Merge option. Use that. I'm going back to edit that part of the previous post. Too bad the editor doesn't offer a line-through tag.
    Last edited: Oct 15, 2011
  4. NYHorsewoman
    Offline

    NYHorsewoman iPad Fan

    Joined:
    May 19, 2011
    Messages:
    282
    Thanks Received:
    6
    Trophy Points:
    0
    Ratings:
    +6 / 0
    Well, did all of that, but didn't get a merge option, it just said I will probably get duplicates which I did!

    Instead I deleted all the local contacts and just used the gmail ones which is what I keep up to date anyway.
    Last edited: Oct 16, 2011
  5. twerppoet
    Offline

    twerppoet iPad Legend

    Joined:
    Jan 8, 2011
    Messages:
    16,448
    Thanks Received:
    2,047
    Trophy Points:
    113
    Location:
    Walla Walla, WA
    Ratings:
    +2,352 / 1
    Ok, sorry it did not work, but glad you found your own solution.
  6. NYHorsewoman
    Offline

    NYHorsewoman iPad Fan

    Joined:
    May 19, 2011
    Messages:
    282
    Thanks Received:
    6
    Trophy Points:
    0
    Ratings:
    +6 / 0
    I wonder why I didn't get a merge option.....
  7. twerppoet
    Offline

    twerppoet iPad Legend

    Joined:
    Jan 8, 2011
    Messages:
    16,448
    Thanks Received:
    2,047
    Trophy Points:
    113
    Location:
    Walla Walla, WA
    Ratings:
    +2,352 / 1
    No idea. Since you probably still have the iPad contacts, be sure to got into Settings > Mail, Contacts, Calendars and set the default under Contacts to the GMail account. That should help insure that new entries get in the right place.
  8. NYHorsewoman
    Offline

    NYHorsewoman iPad Fan

    Joined:
    May 19, 2011
    Messages:
    282
    Thanks Received:
    6
    Trophy Points:
    0
    Ratings:
    +6 / 0
    Interesting. I was just playing around with contacts and notice that not all information is in there for all contacts. For example, I have a few contacts where it is just their name in there, no phone number transferred over. It's very weird.
  9. twerppoet
    Offline

    twerppoet iPad Legend

    Joined:
    Jan 8, 2011
    Messages:
    16,448
    Thanks Received:
    2,047
    Trophy Points:
    113
    Location:
    Walla Walla, WA
    Ratings:
    +2,352 / 1
    Not good. Is the information there on the Google side?
  10. NYHorsewoman
    Offline

    NYHorsewoman iPad Fan

    Joined:
    May 19, 2011
    Messages:
    282
    Thanks Received:
    6
    Trophy Points:
    0
    Ratings:
    +6 / 0
    Yes, the info is all there on the Google side. I just went back into the cloud to see if the contacts are still there and they are. So I went back into the settings on the iPad 2 and checked off the contacts to include them and now it seems like the contacts are fine again and I don't see doubles! I checked off the box to see all contacts and I still don't see doubles. So I don't know what's going on, but it seems like it is all there now and okay, just confusing.
  11. twerppoet
    Offline

    twerppoet iPad Legend

    Joined:
    Jan 8, 2011
    Messages:
    16,448
    Thanks Received:
    2,047
    Trophy Points:
    113
    Location:
    Walla Walla, WA
    Ratings:
    +2,352 / 1
    When you select the All Contacts options it shows you all the information from both databases for each contact. If you go down to that box you were at before, you should see options for iPad and Google. You can select one to see what info is in only that entry.

    Sounds like however it happened, iCloud ended up with a complete database. I haven't been able to find anyway to export or import to iCloud, or I'd recommend combining it with Google on the server.
  12. twerppoet
    Offline

    twerppoet iPad Legend

    Joined:
    Jan 8, 2011
    Messages:
    16,448
    Thanks Received:
    2,047
    Trophy Points:
    113
    Location:
    Walla Walla, WA
    Ratings:
    +2,352 / 1
    That is old info, btw (random revisit). icloud.com now allows the importing and exporting of Contacts as vCard files. While this won't allow you to sync iCloud and Google, it will let you export/import data between them.

    icloud.com can only be visited from a computer using a fairly up-to-date browser.
  13. wipednwired
    Offline

    wipednwired iPF Noob

    Joined:
    Mar 21, 2012
    Messages:
    7
    Thanks Received:
    0
    Trophy Points:
    0
    Location:
    Dublin
    Ratings:
    +0 / 0
    This is a bit of a different problem, but when I sync to outlook, it sometimes adds the home address again. So I have a bunch of contacts with two identical entries for home address. Anyone know how I can stop this?
  14. twerppoet
    Offline

    twerppoet iPad Legend

    Joined:
    Jan 8, 2011
    Messages:
    16,448
    Thanks Received:
    2,047
    Trophy Points:
    113
    Location:
    Walla Walla, WA
    Ratings:
    +2,352 / 1
    If you are syncing both through iTunes (settings in the Info tab) and online through iCloud or another service you can end up creating a loop that will duplicate contacts. If so, I recommend turning off the iTunes syncing. Sync both the iPad and computer directly to iCloud, Google, or whatever online service you are using.

    The other possibility is lag. Because direct syncing with iTunes only happens once or twice a day (depending on how often you sync), you can end up editing on both devices before the next sync. When this happens there is a conflict. Usually the iPad or computer should ask you to resolve the contact; but if it does not the default is to keep both versions.

    Again, my recommendation is to not sync through iTunes.

    There are other possible reasons for duplicates, but this is the most common.
  15. marciajscott
    Offline

    marciajscott iPF Noob

    Joined:
    Jul 8, 2012
    Messages:
    3
    Thanks Received:
    0
    Trophy Points:
    0
    Ratings:
    +0 / 0
    Is there a way to delete duplicates, besides manually?
  16. twerppoet
    Offline

    twerppoet iPad Legend

    Joined:
    Jan 8, 2011
    Messages:
    16,448
    Thanks Received:
    2,047
    Trophy Points:
    113
    Location:
    Walla Walla, WA
    Ratings:
    +2,352 / 1
    There are third party apps that promise to give you tools for deleting/managing your contacts. I'm not familiar with any of them, but a search of the App Store should turn up a few.

    For myself, I just do it on the the computer or the server (via the web site) and let the changes sync back to the iPad.

Share This Page

Search tags for this page
contacts doubled on ipad
,
contacts doubled on iphone
,
contacts duplicate information
,
how do i merge contacts on ipad
,
how to combine 2 contacts on iphone 4s
,

how to merge contacts on iphone 4s

,
ipad contacts doubled
,
ipad unified contacts
,
iphone 5 combined contacts with no last name
,
merge contacts
,
unify iphone ipad contacts