What's new
Apple iPad Forum

Welcome to the Apple iPad Forum, your one stop source for all things iPad. Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

iPad 2 stuck on apple logo HELP =(

vintage77

iPF Noob
Joined
Mar 20, 2012
Messages
1
Reaction score
0
I decided to jailbreak my iPad2 5.0.1 using Absinthe(version 0.4). Everything went smoothly until I opened cydia for the first time. After about 15 minutes, i noticed the loading animation stopped, so i figured It hanged. Tried pressing the home and power button but to no avail. So I tried resetting the device by holding the power and home button at the same time. I guess I can get it back to work but I don't want to update to 5.1 (I want it jailbroken). I tried entering DFU and installing 5.0.1 by the shift + restore method but I always get error 3914. I tried using TinyUmbrella to fix the host file but I still get the error. Any Ideas =(
 

HappyPelican

iPF Novice
Joined
Jul 21, 2011
Messages
311
Reaction score
15
Location
Pelican Island, NJ
Did you jailbreak tethered or untethered? Sound like it needs to be rebooted tethered, at least that's what a tethered job sounds like.
 

Most reactions

Latest posts

Top