What's new
Apple iPad Forum 🍎

Welcome to the Apple iPad Forum, your one stop source for all things iPad. Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

iPad 2 Safari “Open Windows†button not working - iOS 4.3.5


iPF Noob
Jul 29, 2011
Reaction score
In my recently acquired iPad2 (1 week!), the Safari "open windows" button is not working. All the rest of the buttons work fine, except this one... The oddest thing is that when I "long-tap" a link and choose "Open in a new page", the animation shows all the other windows (though I can't tap/select/close any of them) before opening the new page...

Deleting the Safari cache/history works to get a new "blank" page but not to get the button working. I've tried closing Safari, powering off and even "rebooting" (home-sleep for 15 seconds) the iPad with the same result.

This was working fine before; I updated to 4.3.5 yesterday so I'm blaming it on that...

Any ideas? It's really a PITA not to basically be able to use Safari...


Try one more thing...

See if completely closing the app works; double-tap the Home button to open the multi-task bar, touch and hold any icon until they all start to jiggle and then touch the upper top left of the Safari icon. This will remove the app's 'context' file (its 'state'). Then either tap the Home button or the main screen to close the multi-task bar and try again.

Good Luck....

Glad to hear!!

Let us know if you have any more issues - that's what we're here for....

I'm having the same issue but hard-closing the app did not work for me. Any other ideas. Thanks

Most reactions

Latest posts