What's new
Apple iPad Forum

Welcome to the Apple iPad Forum, your one stop source for all things iPad. Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

? How to Delete Duplicate Events in Calendar?

kitjv

iPF Noob
Joined
Oct 9, 2011
Messages
20
Reaction score
0
Join Date: Sep 2005
Posts: 5


icon5.gif
Duplicates in Calendar
permalink

The calendar on my iPad2 is synced via iCloud to both of my Macs. For some reason, all of the events on the iPad2 calendar are duplicated. However, that is not the case on either the calendar on iCloud or my Macs.

Unfortunately, if I delete any of the dupes on the iPad2, that event will be completely deleted from both iCloud & my Macs (since they are all synced).

So, how can I delete the duplicated events on the iPad2 without affecting those same events on iCloud or my Macs,

Thank you kindly for any help.
 

Wokiebear

iPF Novice
Joined
Feb 6, 2011
Messages
173
Reaction score
7
Check to see if you have two calendars set up. I had that problem because I sync everything thru Google calendar, but didn't turn off the onboard built-in calendar. Turned off the onboard calendar....viola no more dupes.
 

twerppoet

iPad Fan
Joined
Jan 8, 2011
Messages
22,046
Reaction score
9,064
Location
Milton-Freewater, OR
Try this.

Go to Settings > iCloud and sign out of the account.

Now go to Settings > Mail, Contacts, Calendars and see if you still have an iCloud account. If you do, delete it.

In both cases choose to delete the contacts and calendars. This only deletes them from the iPad, not iCloud or the Mac, so your data is safe.

Now go back to Settings > iCloud and sign back in.
 
OP
kitjv

kitjv

iPF Noob
Joined
Oct 9, 2011
Messages
20
Reaction score
0
Wokiebear said:
Check to see if you have two calendars set up. I had that problem because I sync everything thru Google calendar, but didn't turn off the onboard built-in calendar. Turned off the onboard calendar....viola no more dupes.

No, I only have one calendar.
 
OP
kitjv

kitjv

iPF Noob
Joined
Oct 9, 2011
Messages
20
Reaction score
0
twerppoet said:
Try this.

Go to Settings > iCloud and sign out of the account.

Now go to Settings > Mail, Contacts, Calendars and see if you still have an iCloud account. If you do, delete it.

In both cases choose to delete the contacts and calendars. This only deletes them from the iPad, not iCloud or the Mac, so your data is safe.

Now go back to Settings > iCloud and sign back in.

Thank you for the suggestion, but I happily resolved the problem. I simply went to Settings > iCloud & turned off calendar syncing. When prompted, I chose to delete all events from the iPad calendar. When I turned syncing back on, the calendar was restored with no dupes. Thanks again.
 
Last edited:

jcherepy

iPF Noob
Joined
Jul 25, 2010
Messages
108
Reaction score
0
Location
Georgia
I also have the same problem. I deleted all calendars from the iPad and iPhone, my Outlook calendar only has two appointements in it for the entire year, but If I go to icloud.com and log in and look at calendars, I still see THREE of every event. I'm at wit's end.

Thanks,
 

twerppoet

iPad Fan
Joined
Jan 8, 2011
Messages
22,046
Reaction score
9,064
Location
Milton-Freewater, OR
If at some point in the syncing cycle you duplicated those appointments for real, then the only way to get rid of them will be to manually delete the extras.

Visit icloud.com on a computer and check out the Calendar app. If they are duplicated there, then manual deletion it is.
 

jcherepy

iPF Noob
Joined
Jul 25, 2010
Messages
108
Reaction score
0
Location
Georgia
I went to icloud.com and there were dups there. I deleted the dups, but now when I sync the remaining event does not show up on either my iPhone or iPad. I'm sorry, but iCloud stinks.

Thanks for taking time to reply.
 

jcherepy

iPF Noob
Joined
Jul 25, 2010
Messages
108
Reaction score
0
Location
Georgia
OK, thanks to my smart daughter, I followed her suggestion and downloaded and installed the iCloud Control Panel on my PC and used that to sync and the Calendar on my iPad and iPhone are in sync with Outlook.
 

twerppoet

iPad Fan
Joined
Jan 8, 2011
Messages
22,046
Reaction score
9,064
Location
Milton-Freewater, OR
jcherepy said:
OK, thanks to my smart daughter, I followed her suggestion and downloaded and installed the iCloud Control Panel on my PC and used that to sync and the Calendar on my iPad and iPhone are in sync with Outlook.

I didn't realize you were missing that part. Glad your smart daughter was around to straighten us out. :)
 

sanderson

iPF Noob
Joined
Nov 28, 2011
Messages
2
Reaction score
0
iCloud pc settings error

So, trying to set up iCloud to sync contacts and calendar on my pc (window7) and get error 0x80004005. Can't complete so relying on iTunes to sync with outlook. Creates multiple duplicates of some entries (6 plus sometimes) and not of others. Any ideas how to do any of the following? Also note, apple genius bar was unsuccessful...they sent me to the windows store....who were also unsuccessful in resolving my issue. For background, I have many items in outlook that I pulled over from an exchange server which is no longer in play. I use gmail for email. So very few ofcontacts and none of my calendar entries are in gmail.

1) fix error mentioned above so I can sync with iCloud. The error could have to do with windows defender ( which is turned off by the way in lieu of Symantec protection). Supposed solution is to turn off system restore, reboot, then turn on again. Tried it...still receive the error at tail end of setting up iCloud sync. Ugh!

2) set up for calendar entries to merge upon sync instead of multiple entries?

3) delete duplicate entries in any way aside from opening each calendar entry individually to edit and delete.

Side note...i wonder if every time I plug into iTunes to sync that it creates new entries for some items....is there a setting to fix this?

Any help is much appreciated. I am feeling regrets for trying to switch to iPad/iPhone....it shouldn't be this hard!

Thanks in advance!

S
 

Gschrade

iPF Noob
Joined
Nov 13, 2012
Messages
2
Reaction score
0
Hi,

I have duplicate calendar events on my iPad. I am not using the iCloud calendar, it has been set to off. My duplicates are from my gmail account contacts. I deleted the contacts out of gmail and those events don't show up when logged into gmail. I had the similar issue with my iPhone. I deleted my gmail account on my iPhone and then added it back. The duplicates were gone. Tried the same thing with the iPad with no luck. How do I remove these events, I can select it but have no delete option?

Thanks for any suggestions!
 

Gschrade

iPF Noob
Joined
Nov 13, 2012
Messages
2
Reaction score
0
After messing around in the settings, my wife discovered turning off the Facebook calendar removed the duplicate entries.
 

Most reactions

Latest posts

Top