What's new
Apple iPad Forum

Welcome to the Apple iPad Forum, your one stop source for all things iPad. Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Handbrake causing jagged lines?

katieB

iPF Noob
Joined
Jul 7, 2010
Messages
14
Reaction score
0
Hi,

I've been hearing how great Handbrake is for converting DVD files for the ipad, so I've been trying it out - version 0.9.4 for Windows. No matter what I try, I keep getting jagged lines (mouse teeth) in my results. Turning on the "Decomb" helps, but the lines are still there. How to match the quality of the DVD files as faithfully as possible? These files came from a PAL DVD (so framerate of 25?). Any help is much appreciated as I am completely new to this :).

Settings I tried

Codec: h.264
Framerate: Same as Source (2 pass grayed out)
Constant Quality: 60.78% RF 20

Presets: Normal, AppleTV, High Profile
Anamorphic: Strict, Loose
Decomb: Default (what to put for custom?)

Advanced Settings: Left at Defaults for each Preset


One more thing. I downloaded presets for the iPad, but Handbrake won't let me import them. The presets file is .xml and Handbrake seems only to want files of type "Plist". Any ideas? Can't understand how others are getting such great results.
 

Hasty

iPF Novice
Joined
Jun 2, 2010
Messages
2,266
Reaction score
22
Location
Location
Might I suggest you check out Lifehacker, tips and downloads for getting things done
They had an article about a week ago regarding iPad settings for Handbrake.
I copied the settings onto my win7 box and they are working really well. I believe there were also instructions for mac users.

Also Handbrake is in active developement so you could go to their webpage and download the latest build. It might help .
 
OP
K

katieB

iPF Noob
Joined
Jul 7, 2010
Messages
14
Reaction score
0
Oops! I just realized something. My DVD files had been put through a decrypter sometime ago. When I played the originals again in VLC Player, I could see the dreaded jagged lines. So it looks like Handbrake matched that quality pretty close. LOL! Sorry I did not remember that before. :eek:

Not sure why I decrypted b/c the DVD isn't protected. (FYI I do own the DVD and am not trying to redistribute/profit off of it - just want to play it to look good in QuickTime & iPad.) For the future -- if I have to decrypt my other DVDs, is there a particular method for preventing the "combing" effect from happening?

Thanx for any suggestions!
 
OP
K

katieB

iPF Noob
Joined
Jul 7, 2010
Messages
14
Reaction score
0
No ideas how to prevent the artifacts when I convert? I have several more DVDs to work with. It is looking like a painful ordeal :(
 

MikesTooLz

iPF Novice
Joined
May 7, 2010
Messages
2,361
Reaction score
20
Location
Miami, FL
Website
Weather.Team
I have no issue with handbrake.
I'm running the MAC version. Didn't change anything from the default installed settings.
I choose the Apple TV presets and it rips the movie.


Can you post a screen shot of what your getting.
 
Last edited:
OP
K

katieB

iPF Noob
Joined
Jul 7, 2010
Messages
14
Reaction score
0
MikesToolz,

Thanks for your reply. If I have done this correctly, here is the screenshot of my results when I choose AppleTV setting in Handbrake:

appleTVsetting.jpg

Sorry I was not successful getting a screenshot of this when playing it back in WIN DVD. But basically, the lines (which you can faintly see in WIN DVD) are MUCH more noticeable once Handbrake does its thing. This was about the best I could get after endless tinkering around with profiles, decombing, frame rates, etc. This particular sample I just did as you suggested and chose "AppleTV" and left everything else at default.

Is this as good as it gets? I should probably mention the DVD source says the file size is 720 by 576, which I did not try to change. Thanks for any suggestions :)
 

MikesTooLz

iPF Novice
Joined
May 7, 2010
Messages
2,361
Reaction score
20
Location
Miami, FL
Website
Weather.Team
Oh....
That is because the particular DVD your ripping is using Interlacing. You will have to tell handbrake to Deinterlace to try and fix it.

in the handbrake toolbar select Picture Settings.
Select the Filters Tab
Change the slider from Decomb to Deinterlace.



Not all DVD's use interlacing but you can tell if they do when they look like that.
 
OP
K

katieB

iPF Noob
Joined
Jul 7, 2010
Messages
14
Reaction score
0
Hooray!

Turning on the Deinterlace seems to have fixed my issue! I thought that setting was only necessary for animations, so I had not tried it before. Weirdly, this + the AppleTV preset made my movie look much better. It's actually enjoyable to watch now! Thanks everyone for the great input. I have learned alot. :D
 

Most reactions

Latest posts

Top