What's new
Apple iPad Forum 🍎

Welcome to the Apple iPad Forum, your one stop source for all things iPad. Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Apple tv not playing music from the I tunes library?

Thomasp

iPF Noob
Joined
Dec 7, 2012
Messages
63
Reaction score
3
Set up the Apple tv box.

Everything appeared fine, tried most things and they worked (airplay from pad, you tube etc etc)
Tried the music sharing from the pc and it worked fine.
Went back on later and it will not now play music from my i tunes library via the "computer" selection which shows in the menu. This selection normally brings up all the available i tunes stuff (music, videos) on my pc.
When I click on that selection I get a message saying I need to turn on home sharing on the pc inside the I tunes programme, but it is turned on?

Anybody have any idea what I am doing wrong?
I am working purely with wi-fi connection by the way. The annoying thing is it was working?
Would an ethernet connection be better?
 
OP
T

Thomasp

iPF Noob
Joined
Dec 7, 2012
Messages
63
Reaction score
3
Kevin, thanks much but I found out he problem after some detective work. Apple certainly don't make it easy for you with I Tunes.

I had selected turn on home sharing in the "file" drop down menu, but it seems you still have to go into "preferences" in the edit drop down menu. Look for the "sharing" option and either select "share the entire library" or do a selective sharing choice.
Strange thing is it was working when I first connected the apple tv box???
 

KevinJS

Super Moderator
Staff member
Joined
Aug 6, 2011
Messages
10,665
Reaction score
1,470
Location
Edmonton AB Canada
Kevin, thanks much but I found out he problem after some detective work. Apple certainly don't make it easy for you with I Tunes.

I had selected turn on home sharing in the "file" drop down menu, but it seems you still have to go into "preferences" in the edit drop down menu. Look for the "sharing" option and either select "share the entire library" or do a selective sharing choice.
Strange thing is it was working when I first connected the apple tv box???

Thanks for the feedback. I must have set that up ages ago on my PC and forgotten about it. Thing is, my Mac is brand new, and I certainly haven't set that up on it. I'll go take a look.

EDIT: It's set up by default on the Mac.
 
Last edited:
OP
T

Thomasp

iPF Noob
Joined
Dec 7, 2012
Messages
63
Reaction score
3
The other basic thing as far as I can see is that the pc needs to be turned on and I Tunes needs to be open.
My pc is not wireless so perhaps this only applies to similar set ups?
 

Most reactions

Latest posts

Top