Text list formatting ( transpose ) text to columns HELP

Discussion in 'iWork Forum' started by nebunuloko, Aug 7, 2011.

  1. nebunuloko

    nebunuloko iPF Noob

    Joined:
    Aug 7, 2011
    Messages:
    9
    Thanks Received:
    3
    Trophy Points:
    0
    Ratings:
    +3 / 0
    I have an export of my installed apps from my iPad in this format :

    360
    Version : 4.0.1
    Id : com.occipital.360Panorama
    Folder : C0232A79-71B7-460D-8B57-685400F57094
    Bundle : 360.app
    Name : 360 Panorama
    Author : Occipital
    Section : Photography
    Copyright : © Occipital, LLC
    Price : £0.59
    Bundle Version : 4.0.1
    Purchase Date : Unknown
    Genre ID : 6008
    Open in Appstore

    And they are 217 apps in such a list.

    My problem is that when I hit paste in numbers, all of this information gets placed in a single cell, and not each line in a single cell.

    How could I format my text, or somehow achieve this thing?

    I googled and googled ... But found no answer.

    Ps. I don't want a solution that implies using another device other than the iPad itself .

    Thank you.
     
  2. twerppoet

    twerppoet iPad Legend

    Joined:
    Jan 8, 2011
    Messages:
    17,291
    Thanks Received:
    2,474
    Trophy Points:
    113
    Location:
    Walla Walla, WA
    Ratings:
    +3,034 / 1
    Change the file extension from .txt to .csv, then import it into Numbers instead of trying to paste it. It will create a new document with a spreadsheet and a table. Each line entry will become one cell. (except lines containing commas, that will be broken up into multiple cells)

    If you to break the line up using commas, each comma separated value (csv) will be come it's own cell.

    The name change and editing part would be a lot easier to do on a computer, but since you want to avoid that, I experimented with a painfully long workaround. You will need Pages and GoodReader, as well as Numbers.

    (Optional, if you want to separate lines into cells)
    Copy and paste the list into Pages. There you can can use the Find and Replace feature in Pages to change ' :' to ','. Use the Find option under the wrench icon. Tap the gear icon at the left of the Find editor to change to Find and Replace. Fill out each field with the find and replace text. Tap and hold Replace for a popup Replace All menu. Hold in mind that commas already present will also create cells. that means the Copyright line will become three, instead of two cells. Now Select All and copy the text from the Pages document.

    (less Optional)
    Open GoodReader, select Manage Files from the right column, tap Manage Files, then New TXT. Paste the text into the resulting document. Save the document. Close, and go back to GoodReader's file view using the button at the top left.

    Tap Manage Files, select the newly created (New Text.txt) file from the left column. Tap Rename, and change the extension to ".csv". Just add the extension (including the .) and GoodReader will ask you if you want to ti replace txt. Say yes.

    Select the file again, then choose ... Open In from the Manage Files dialog, and choose Numbers.

    Numbers will open, import, and create a new document and table. It will probably take a great deal of playing around to make that table look the way you want. Or, you can select, copy, and paste those cells into another spreadsheet and table.

    If there is an easier way to do this, I have not discovered it yet. If you find a better way, please let us know.
     
    Last edited: Aug 7, 2011
  3. nebunuloko

    nebunuloko iPF Noob

    Joined:
    Aug 7, 2011
    Messages:
    9
    Thanks Received:
    3
    Trophy Points:
    0
    Ratings:
    +3 / 0
    Nice trick with the renaming of the .xls to .csv ;)

    I've managed to this using these simple stepts.

    Copied the entire bunch of text

    Paste it to Textastic

    Renamed the file from .txt to .csv

    Opened the file in Textastic and chosed open in numbers.

    The lines where separated !

    Thank you very much for this hint.
     
  4. nebunuloko

    nebunuloko iPF Noob

    Joined:
    Aug 7, 2011
    Messages:
    9
    Thanks Received:
    3
    Trophy Points:
    0
    Ratings:
    +3 / 0
    How come the separating with a comma "," didn't make two columns for me?
    Tried first with replacing the ":" with "," ex : "Name :" became "Name ,"
    And then another file with replacing the " :" with "," ex: "Name :" became "Name,"
     
  5. twerppoet

    twerppoet iPad Legend

    Joined:
    Jan 8, 2011
    Messages:
    17,291
    Thanks Received:
    2,474
    Trophy Points:
    113
    Location:
    Walla Walla, WA
    Ratings:
    +3,034 / 1
    I'm not sure. It worked for me. I copied, pasted, and edited the sample you provided in my tests. Perhaps Textastic is using something other than standard ASCII or Unicode when encoding the files. That is all I can think of.
     

Share This Page

Search tags for this page
apps that transpose numbers to tex
,
how do you copy and paste transpose in apple numbers
,
how to text to columns in numbers mac software
,
how to transpose text in textpad
,

mac numbers text to columns

,
text to columns in apple numbers
,
text to columns in apple numbers?
,
text to columns in osx numbers
,
text to columns iwork numbers
,
transpose a column in apple numbers