1. Due to the recent site upgrade, the iPadForums (iPF) App will no longer work. The new iPadForums.net website has been designed from the ground up to work perfectly from any mobile, tablet, or desktop computer using the built in internet browser. Create a shortcut to iPadForums.net on your home screen by following these steps: Create an icon for iPadForums.net

Messed up iPod & video apps-pls Help

Discussion in 'iPad Hacking' started by Johnnyk5679, Aug 6, 2011.

  1. Johnnyk5679
    Offline

    Johnnyk5679 iPF Noob

    Joined:
    Aug 6, 2011
    Messages:
    5
    Thanks Received:
    0
    Trophy Points:
    0
    Location:
    Dublin
    Ratings:
    +0 / 0
    Hi guys,

    Another noob to the forum in major crisis. Not new to iPhones etc but just got the iPad a few days ago. Was messing around, changing the default back cover image and no albumart stock images on the albums within the iPod app , I Respringed and lost the iPod and video app icons. I can still play music and video through ifile but I really want my icons back and working.

    I'm on 4.3.3 so don't want to restore to 4.3.5. Only got it recently so no shsh blobs saved so I can't reinstall 4.3.3 and I dont want to loose my jailbreak.

    Can I reinstall the iPod/video apps somehow. Have an iPhone 4 with 4.3.3 - could that be used to copy files from phone to iPad??

    I'd really appreciate some expert help...I'm pulling my hair out!!

    Thanks in advance!

    John
  2. verbalj
    Offline

    verbalj iPF Novice

    Joined:
    Jul 15, 2011
    Messages:
    64
    Thanks Received:
    1
    Trophy Points:
    0
    Location:
    NYC
    Ratings:
    +1 / 0
    If it's just the icons missing, I would check under SBSettings (if you have it installed) to see if the icons were turned off. I know when a couple of my icons disappeared (I didn't uninstall them), the first thing I did was check to see if they were turned off in SBSettings. I dunno how or why they were, but sure enough, they were turned off.
  3. Johnnyk5679
    Offline

    Johnnyk5679 iPF Noob

    Joined:
    Aug 6, 2011
    Messages:
    5
    Thanks Received:
    0
    Trophy Points:
    0
    Location:
    Dublin
    Ratings:
    +0 / 0
    I wish it was that simple but I tried that to no avail, they are switched on...think there something more serious as it comes up with this message if I try to select a song froma spotlight search:

    URL unsupported

    URL not loaded

    Search//:Com.apple.mobileipod-audio player.......

    And also, the icons disappeared.
  4. Gabriel1
    Offline

    Gabriel1 Super Moderator Staff Member

    Joined:
    Mar 11, 2011
    Messages:
    17,132
    Thanks Received:
    746
    Trophy Points:
    0
    Location:
    Cranbrook, Kent, UK
    Ratings:
    +747 / 0
    I have moved this into the hacking forum where you may get more appropriate help.

    The Archangel
  5. Mickey330
    Offline

    Mickey330 Administrator Staff Member

    Joined:
    Aug 30, 2010
    Messages:
    11,367
    Thanks Received:
    1,647
    Trophy Points:
    113
    Location:
    Western NY state (USA)
    Ratings:
    +1,743 / 0
    Ouch!

    So, in your playing around - you were in iFile?

    Specifically, what files did you change or delete?

    Marilyn

    Who is really not holding out hope this can be fixed short of a restore...
  6. Johnnyk5679
    Offline

    Johnnyk5679 iPF Noob

    Joined:
    Aug 6, 2011
    Messages:
    5
    Thanks Received:
    0
    Trophy Points:
    0
    Location:
    Dublin
    Ratings:
    +0 / 0
    Hi,

    I changed the Coverflowplaceholder44.png which Is the "?" for the cover flow when you don't have the album art and the same file but with "@2x.png" so the large and the small image also the noartplaceholder.png file and the smaller one which is the image you see when you click on a song and it's the album art in the background.

    That all went fine, then I said I'd change the nowplayingtablebackground.png file which is the back cover-thats when it all went wrong.

    I should mention that I had an app called music flow which is a cover flow for iPad. Again I changed similar files within that app so there was something instead ofvthe stock image if there was no album art.

    It was when I changed the previously mentioned nowplayingtablebackground.png file back in mobilemusicplayer.app resprung then good night iPod and video app icons!!!!

    Sorry for the long answer but that's the detail-I've since change things back to the way they were before I messed things up but it still hasnt returned, rebooted etc no joy
  7. Johnnyk5679
    Offline

    Johnnyk5679 iPF Noob

    Joined:
    Aug 6, 2011
    Messages:
    5
    Thanks Received:
    0
    Trophy Points:
    0
    Location:
    Dublin
    Ratings:
    +0 / 0
    Sorry, to clarify the coverflowholder file was in the music flow app obviously as there is no coverflow originally in the iPad.....so I was basically replacing the question Mark image that you see for albums without album art in the main iPod app as well as this other cover flow app, music flow.
  8. Johnnyk5679
    Offline

    Johnnyk5679 iPF Noob

    Joined:
    Aug 6, 2011
    Messages:
    5
    Thanks Received:
    0
    Trophy Points:
    0
    Location:
    Dublin
    Ratings:
    +0 / 0
    Sorted problem by reading lots of forums , the permissions for the mobilemusicplayer.app were wrong, should have been user: read write execute, group: read write execute, world: read execute

    Happy days!!!!!!!!!!!!
  9. Mickey330
    Offline

    Mickey330 Administrator Staff Member

    Joined:
    Aug 30, 2010
    Messages:
    11,367
    Thanks Received:
    1,647
    Trophy Points:
    113
    Location:
    Western NY state (USA)
    Ratings:
    +1,743 / 0
    Whew!

    Glad to hear it got sorted!

    Marilyn
  10. Poser
    Offline

    Poser iPad Junkie

    Joined:
    Jul 2, 2011
    Messages:
    816
    Thanks Received:
    27
    Trophy Points:
    0
    Location:
    toronto
    Ratings:
    +27 / 0
    i was freaking out on this one, and was about to say, did you do a pkgbackup that you could restore to, or would a simple restore from backup would've helped.

    cherish your no blobs 4.3.3 son....
  11. verbalj
    Offline

    verbalj iPF Novice

    Joined:
    Jul 15, 2011
    Messages:
    64
    Thanks Received:
    1
    Trophy Points:
    0
    Location:
    NYC
    Ratings:
    +1 / 0
    Nice! Thanks for posting the solution too, some people never come back. How does that help the community?

Share This Page

Search tags for this page

i messed up things in ifile

,

messed up in ifile now iphone doesnt play videos

,

unsupported url