What's new
Apple iPad Forum

Welcome to the Apple iPad Forum, your one stop source for all things iPad. Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

More Hd Copilot Complaints

Morty

iPF Noob
Joined
Jul 8, 2010
Messages
1
Reaction score
0
We're new to the Apple world with the purchase of our Pad 3 G 64 gig. We wanted a navigation system to use on our I pad when we traveled. We purchased an HD Co-Pilot and initially used it with some success in the Santa Barbara area. However, when we tried to use it on a trip to Park City, Utah, it was totally unacceptable. It repeatedly hung after trying to load the app. We could not input a destination or select anything on the menu. This problem persisted in Salt Lake City as well as Saint George and Las Vegas during our drive to Park City. Google Maps and Google Earth worked perfectly in all these places.

Right now, we wouldn't recommend this program to anyone and are extremely sorry we paid $30.00. Our kids were right - "Don't ever pay for an app!"
 

Hasty

iPF Novice
Joined
Jun 2, 2010
Messages
2,266
Reaction score
22
Location
Location
Don't know the app in question but a couple of things spring to mind before assuming the app is at fault.
The first would be to delete the app from the iPad and reinstall it on resyncing. Somethings can get corrupted.
Also check if there are adjustable settings available under the iPad's settings icon (the cog wheel one). Maybe the app needs to cache a lot of detail in advance.
Again check the developers website.

Of course it could just be totally useless but apple normally checks out that they work as intended before they appear in the AppStore. All the ones I've tried work as intended but sometimes my expectations were too high.....

For 30$ you expect a lot from an app!
 

col.bris

Administrator
Staff member
Joined
Mar 25, 2010
Messages
5,888
Reaction score
710
Location
Gold Coast , Queensland Australia
I have been using co pilot for some 10 months on an iPhone 3GS this product is one of the best available. I suspect the problem lies with the new HD version I also suggest deleting the App then down load it again. The down load will be free as you own it.

I also suggest reset the iPad holding home button and on/ off keys at same time until Apple logo appears. If the problem still exists email copilot developers. You also can request you money back from iTunes store if program is faulty.
 

Most reactions

Top