What's new
Apple iPad Forum 🍎

Welcome to the Apple iPad Forum, your one stop source for all things iPad. Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

iOS11: Language change failure

iBozz

iPF Novice
Joined
Mar 25, 2012
Messages
145
Reaction score
33
Location
NW England
As I am learning, or attempting to learn, Welsh I changed my preferred language to Welsh via Settings > General > Language & Region > Other Languages > iPad Languages > Other Languages > Cymraeg.

All well and good.

However, as a couple of apps seemed to have a bug and wouldn't work at all in Welsh (not just not support Welsh, they failed to work at all), I decided to switch back to only English.

Everything changed back except the iPad's Keyboard, which still resolutely shows dychwelyd for return and dad-wneud for undo.

These are not showstoppers and I can live with this but there may be other, as yet undiscovered, Welsh remnants in there somewhere, so why has this happened and how can I fully restore to the default English Language?

Diolch yn fawr!
 

J. A.

Super Moderator
Staff member
Joined
Nov 11, 2012
Messages
25,871
Reaction score
26,149
Location
Apetlon, Austria
It looks like you’ve also enabled a Welsh keyboard. Go to Settings - General - Keyboard - Keyboards, and slide the keyboard you don’t need to the left, so that you can remove it:
407AC9A0-75AF-4040-89C0-8107DDBAE95B.jpeg
 
OP
iBozz

iBozz

iPF Novice
Joined
Mar 25, 2012
Messages
145
Reaction score
33
Location
NW England
Many thanks, JA, that indeed does look like the cause.

When I changed to Welsh under iOS.10 it presumably either did not change the keyboard or it did and when I changed back to English it automatically switched the keyboard back as well.

Under iOS.11 it seems not to revert to the English keyboard automatically as I have no recollection (under 10 or 11) of changing the keyboard.

I could be suffering from memory loss, of course, but that's my recollection. Whatever happened, the problem is now resolved - diolch yn fawr!
 
OP
iBozz

iBozz

iPF Novice
Joined
Mar 25, 2012
Messages
145
Reaction score
33
Location
NW England
Well how about that!

I have just stumbled upon a globe symbol on my keyboard which pulls up emojis. Well, I hate the vast majority of emojis with a passion so I have only ever pressed it by accident, sworn at the emoji palette and got rid of it.

But just now I saw that it also allows me to switch between English and Cymraeg keyboards! Yes, the keyboard langauage is still set on the path which you gave, but I know see that I can switch quickly and easily between the two.

If I could only find a way to switch off the emoji keyboard (and get rid of the dreadful Undo key next to the space bar when on numbers, but that’s an entirely separate gripe) then the world would be nice and useful again!

Thanks again for you help.
 

brixtonboy

iPF Novice
Joined
May 28, 2016
Messages
405
Reaction score
222
Hi this might help
IMG_2851.JPG

In your keyboards top right it should say edit if you press that you are given the option to delete them.
Simply delete the one you don’t want.
Good luck
 

brixtonboy

iPF Novice
Joined
May 28, 2016
Messages
405
Reaction score
222
Now that should have sorted out the Emoji keyboard, lets see if l or someone with much more knowledge can make your World nice and useful again.
Can you do a screenshot of your keyboard of this Undo key next to the space bar?
IMG_2852.JPG

This is mine whilst writing this post. Next to the space bar left is the microphone key. On the right is numbers and signs.
 
OP
iBozz

iBozz

iPF Novice
Joined
Mar 25, 2012
Messages
145
Reaction score
33
Location
NW England
Bravo, the accursed emojis have gone. Quite why Apple think that they are useful I have no idea!

OK, back to the undo button. This is what I see when set to numbers/symbols ...




IMG_5445.PNG
IMG_5446.PNG
 

brixtonboy

iPF Novice
Joined
May 28, 2016
Messages
405
Reaction score
222
Funny that, mines the same. If you press one of the #+= keys it goes away. But you must remember to press ABC key after using numbers.
I have tried 3 times to write this, because I pressed the undo key while it was on.
That would be so annoying, unless during typing a document you setup auto save every 2 minutes or whatever.
IMG_2853.JPG

My first attempt, then l hit undo.
 
OP
iBozz

iBozz

iPF Novice
Joined
Mar 25, 2012
Messages
145
Reaction score
33
Location
NW England
You're right, it is bl@@dy annoying to say the least! I couldn't work out why chunks of my text kept on disappearing when I hit what I thought was the space bar and it took me a while to work out that it was this totally unwanted button!

Thanks, at least I now know how to get rid of it, albeit temporarily. I sometimes thought that a permanent removal involving the use of a hammer would be appropriate!
 

brixtonboy

iPF Novice
Joined
May 28, 2016
Messages
405
Reaction score
222
Been Googling for the past 20 minutes seems you are not alone. This problem has been around for some years now.
 

brixtonboy

iPF Novice
Joined
May 28, 2016
Messages
405
Reaction score
222
Until you get used to this here might be a way to help.
IMG_2854.JPG

I typed this sentence on the first word l hit the undo key and it was deleted, then the redo key and it came back.
Typed next 3 words and only 3 word were deleted but not the first word. On redo they to came back. And so until the sentence was completed.
Right down to the full stop on the end.
Ps. It’s not -10 yet in Germany thank goodness
 
OP
iBozz

iBozz

iPF Novice
Joined
Mar 25, 2012
Messages
145
Reaction score
33
Location
NW England
Thanks, brixtonboy. I shall experiment, but it seems bizarre to me that the assembled geeks and dweebs at Apple think that this is a useful feature on a numeric keypad but not on an alpha keypad.

Either it is useful (and I personally think it to be a right royal pain in the fundament) or it isn’t - they should have the courage of their convictions!
 

Most reactions

Latest posts

Top