What's new
Apple iPad Forum 🍎

Welcome to the Apple iPad Forum, your one stop source for all things iPad. Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Deleting a music track


iPF Noob
Jan 11, 2014
Reaction score
When I first got my ipad there were some free downloads available one of which was a music track which I downloaded I now don't want it but cannot delete it. I have gone into General settings, music and delete all but the track is still there. Any ideas how to delete it?

Go to the Music app, tap the line of the song, drag it to the left and tap "Delete":
Thanks for your help unfortunately it does not work, I downloaded two tracks from Itunes festival 2013 it looks the same as your screen shot only next to the track time there is a cloud with an arrow through it, if I touch the cloud I get the download circle and when it stops the cloud is gone and I slide to reveal delete tap delete and the cloud reappears and the track is still there. I have looked on icloud but there does not appear to be any music on there.

Slowly losing the will to live.

The cloud means that the song is removed from your device, but you'll always be able to download it again.
Thanks for the reply, the two tracks are still on my ipad and will play without downloading I just want to delete both tracks but I cannot.

I can't find the possibility to remove songs from Settings - Music. Did you delete them in Settings - General - Usage - Storage - Music?

In Settings - Music: try to disable "Show All Music".
One more idea:
Force close Music (double tap Home button to reveal multitasking bar, slide picture above app icon towards the top of the screen).
Go to Settings - iTunes & App Store and sign out there. Wait for a few minutes and sign in again.
Go to Settings > Music and turn off Show All Music.

With Show All Music on, all of your iTunes purchases will show up in the Music app, downloaded or not. Tracks that are not stored locally will have a cloud symbol next to them. They will stream if you tap the track, or download to local storage if you tap the cloud.

With "Show All Music" off you will only see tracks that are stored locally on the iPad.

You can still see and download all your purchased music in the Purchased tab of the iTunes Store.

Disclaimer : This is how I remember it working before I started using iTunes Match. Since I am unable to check on the details I may be mistaken on a few details.
Thanks for all the help.
I have gone into icloud and deleted everything in music and it now says "no data".
When I go to music on my ipad it is still there with a cloud symbol next to it, it just will not delete.

And here are two more suggestions:

Go to Settings - iTunes & App Stores, and disable Music in "Show All". Also disable Music below, in "Automatic Downloads".

Or hide your purchases: http://support.apple.com/kb/ht4919
Last edited:
If you've also tried signing out of your Apple ID and in again, and tried to hide purchases, the only idea left would be to erase all content and settings and restore it: http://support.apple.com/kb/HT1766

Is there an Apple Store near you? If possible, make a Genius Bar reservation, hopefully they can help you solve this problem.
Have tried all suggestions but still no luck.


If you've turned off "Show All Music" in Settings > Music the clouds should go away in the Music app. They will not go away in the Purchased tab of the iTunes Store. Only hiding tracks, which must be done in iTunes on a computer, can do that.

The other possibility is if you are using iTunes Match. iTunes Match is a paid service that makes all your music available on all your devices all the time, even the music you imported from CD's on your computer (into iTunes, of course). You can't get rid of the cloud icons in the Music app with iTunes Match; mostly because it would defeat the purpose of having iTunes Match to begin with.

Most reactions

Latest posts