Not getting iMessages on iPhone

Discussion in 'iPad General Discussions' started by Ipad Now, Nov 3, 2014.

  1. Ipad Now

    Ipad Now
    Expand Collapse
    iPad Fan

    Joined:
    Jun 18, 2013
    Messages:
    108
    Thanks Received:
    4
    I've never had iMessage enabled on my iPhone, I just like getting basic texts. But now when someone texts me with iMessage enabled on their iPhone i don't get them. This started I think when I upgraded my MacBook to Yosemite. I was getting the iMessage texts on the MacBook but not my phone. So I signed out of that on my MacBook but I still don't get them on my iPhone.
    Any help or ideas?
    Thanks
     
  2. scifan57

    scifan57
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Dec 3, 2011
    Messages:
    26,847
    Thanks Received:
    8,383
    Have you gone to Settings>Messages>iMessage to make sure iMessage is turned on? If it's turned off you can't send or receive iMessages.
     
  3. Ipad Now

    Ipad Now
    Expand Collapse
    iPad Fan

    Joined:
    Jun 18, 2013
    Messages:
    108
    Thanks Received:
    4
    I don't want iMessage enabled, I only want sms text messages.
     
  4. delirium trigger

    delirium trigger
    Expand Collapse
    iPF Novice

    Joined:
    Nov 3, 2014
    Messages:
    13
    Thanks Received:
    0
    Yes, but it turned them on for you. You have to turn them off.
     
  5. scifan57

    scifan57
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Dec 3, 2011
    Messages:
    26,847
    Thanks Received:
    8,383
    You have to disassociate your phone number from your Apple ID. Go to Settings>Messages and meme sure iZmessage is turned on, then tap on send/receive and tap on the Apple ID at the top of the page ant tap sign out. Go back to the iMessage page and turn off iMessages. That should work. Now have someone with a non iPhone send you a text message to check it out. Let us know if it doesn't work.
     
  6. Ipad Now

    Ipad Now
    Expand Collapse
    iPad Fan

    Joined:
    Jun 18, 2013
    Messages:
    108
    Thanks Received:
    4
    No this didn't help.
    I keep iMessage off on my phone. Just recently I stopped getting texts from people who have iMessage "on" their phone. What has changed?
     
  7. twerppoet

    twerppoet
    Expand Collapse
    iPad Legend II

    Joined:
    Jan 8, 2011
    Messages:
    20,346
    Thanks Received:
    5,938
    Check your Messages app on the iPad and/or other iOS devices as well, and make sure the phone number is not listed as a recipient. If you have a Mac, same thing.
     
  8. Ipad Now

    Ipad Now
    Expand Collapse
    iPad Fan

    Joined:
    Jun 18, 2013
    Messages:
    108
    Thanks Received:
    4
    Think I've figured it out.
    The people who had iMessage enabled did not have the SMS option turned on and that's why I wasn't getting their texts.
    Thanks to all who helped me.
     
  9. twerppoet

    twerppoet
    Expand Collapse
    iPad Legend II

    Joined:
    Jan 8, 2011
    Messages:
    20,346
    Thanks Received:
    5,938
    Yep, that would do it. Glad you got it sorted.
     
  10. alicepattinson

    alicepattinson
    Expand Collapse
    iPad Fan

    Joined:
    Jan 23, 2013
    Messages:
    183
    Thanks Received:
    11
    Try to go to settings-messages-imessage then turn it on. I hope it help you.
     

Share This Page



Search tags for this page

ipad iphone not getting same imessages

,

not gettimg imessages