What's new
Apple iPad Forum 🍎

Welcome to the Apple iPad Forum, your one stop source for all things iPad. Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

🌟 Exclusive 2024 Prime Day Deals! 🌟

Unlock unbeatable offers today. Shop here: https://amzn.to/3LohMKi 🎁

New Safari Text Protection on ios 11.4.1

NSquirrel

iPF Novice
Joined
Oct 22, 2014
Messages
606
Reaction score
600
Location
UK
Ios 11.4.1 seems to have introduced some new level of protection stopping some text being copied in Safari.

I am working through my Italian course on Duolingo, via Safari on my iPad, and when I had problems with grammar, etc., in a sentence, I went to the accompanying discussion and often copied the explanation into a Pages file. With the update to 11.4.1 I find I can no longer copy any text in the discussion, which is a bit annoying. Btw, this is 11.4.1 related as I can still copy on my Windows 7 PC. (I have sent a bug report to Duoling)

This only seems to affect some web pages and presumably there is some flag that can be set or cleared relating to copying in the web page source or template.

There is a way round it. By using the Safari ‘print to PDF, I can subsequently select and copy what I want in the PDF, paste into my file, and then delete the PDF. Longwinded, but at least it helps.
 
It seems as if the app developer has to make his app fully compatible with iOS 11.4.1. The app developer should have done this while iOS 11.4.1 was still in beta.
 
Quite agree, although it is a web page rather than an app. (In this case I will not hold my breathe for the bug to be corrected... but I will just remain hopeful as with other bugs)
 
Websites have always had the ability to limit copy&paste for thier content. Nothing in the iOS 11.4.1 update should have changed that behavior.

I just did the update, then visited the Duolingo site. Everything I can remember copy&pasting from before still works. Some of the text in the lessons is difficult to copy, because it’s not just text. It’s an active button that does something when you tap on it. These can still, usually, be copied by tap holding somewhat to the side, then sliding your finger across the text when the selection bars appear.

I recomend you restart your iPad and try again. If it still does not work, please give more details on exactly what you are trying to copy on the site. I’ll check it out myself and see if I can figure out what is going on.
 
Thanks for trying it out.

I had tried a reset, but that made no difference.

The problem comes in trying to select text to copy, then paste. I tried a discussion on, of all things, the phrase Arrostiamo qualche patata, which translates to ‘We roast some potatoes’ as I had selected, copied and pasted part of the particular discussion on an area of grammar. Two days ago or so I could select the text, today I cannot.

I tried one other thought and opened the discussion page in iPad Firefox and I can select it there. Strange, but then Firefox has not had an update for a couple of weeks.

Don’t worry about investigating, as I have an alternative way round as described previously. My comment was more to do with highlighting what appears to be a difference in 11.4.1
 

Most reactions

Latest posts

Back
Top