What's new
Apple iPad Forum 🍎

Welcome to the Apple iPad Forum, your one stop source for all things iPad. Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Hotspot authentication issues

gatorguy

iPF Noob
Joined
Jul 29, 2010
Messages
12
Reaction score
0
Location
Florida
I recently traveled for work to Nashville last week and took the iPad along with the netbook. When trying to connect to the Comfort Suites hotspot which redirects you to a logon page where you enter your room number, the Safari browser appears to freeze after typing in the credentials and clicking on the OK button on the screen. I ended up using the Netbook as I needed to connect to the local offices servers.

I am taking a statistics course at a local university and tried connecting to their hotspot last night and experienced the issue again as the iPad connects to the WiFi network and successfully redirects to the authentication screen and then freezes up after typing in the logon credentials.

One similarity I have seen with both the hotel and University was I got a message right when Safari loads that the authentication web site's certificate wasn't secure or something similar to that. I'm assuming they're not paying for a SSL certificate for the local site.

I have tried researching on this and other sites on settings I could adjust on the iPad or trying to have the iPad use another browser instead of Safari as the default browser (Atomic browser) as maybe it would handle the authentication page in a better manner, but no luck so far. I just wanted to see if anyone has had this experience and if anyone had any suggestions on how to resolve this.

I'm heading to the University of Central Florida shortly with my kids for a visit and will bring the iPad with me to see if that campus WiFi has similar issues.

Thanks for any feedback,
Dan
 
I had a similar problem. If you have autofill turned on, this can cause the behaviour you describe. Try turning it off in settings->safari.
 
Steve,

Thanks for the quick reply. I'll give that a try when I'm at the campus this weekend or next week at the latest. I was at the University of Central Florida campus today and had no problems with their network but with that said, the authentication page that comes up doesn't show any messages about not having a valid security certificate.

Thanks,
Dan
 
That fixed it

Thanks for the info. I turned off autofill and the authentication worked like a charm. I wonder why that causes the issue.

Thanks again,
Dan
 

Most reactions

Latest posts

Back
Top