What's new
Apple iPad Forum 🍎

Welcome to the Apple iPad Forum, your one stop source for all things iPad. Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Help for those who get stuck in apple logo mode after a normal reboot with jailbreak


iPF Noob
Jan 1, 2011
Reaction score
Update: Turns out the reason for this problem occurs if you install any cydia application that causes the ipad to run unsigned code at boot this will cause the ipad to not be able to boot normally so if you get this issue just double check to see what cydia apps or extensions you last installed and remove them...if this does not work i think you can just re-install cydia via tethered which should wipe out any added cydia apps if i am not mistaken.

Ok here is a thread for everyone who may have this problem. I am currently using the redsn0w tethered jailbreak for the Ipad 4.2.1 OS as i do not have a mac and do not want to bother with using a virtual machine or whatever to install Mac OS onto the PC just so i can jailbreak it (besides its in beta anyways)

Anyways got it to work fine and installed Cydia apps and the like and learned how to set my ipad into DFU mode for tethered reboots and was installing a Cydia app to allow filesystem access to the ipad while connected by USB to a computer and after installing the app in Cydia it required a reboot...well what i SHOULD have done was press home to exit out of Cydia and perform the tethered reboot via redsn0w instead i stupidly hit the "reboot" button and the ipad then TRIED to reboot into "normal" mode what happend though is this caused the ipad to lock up and get stuck in the white apple logo screen even after restarting several times.

I did manage to get it into recovery mode and tried to restore it in itunes but all it did was go back to the white apple logo screen afterwords

I started to panic! Anyways i followed a suggestion on the forums here to use the jailbreak software to reboot it. i could not boot into DFU mode like i normally do so i simply followed the instructions on the redsn0w program (it is a bit tricky as if you do not do the steps exactly it can sometimes reboot into recovery mode rather then DFU) well anyways i managed to get it to work into DFU mode and it was then a matter of having redsn0w reboot into jailbreak mode ....it did so and got the pineapple logo and at first i thought oh great its still stuck! but after a while it booted up into the normal home screen and got unstuck!

So if anyone had this happend to you (most likely this would apply to teathered jailbreaks as i would imagine the problem would not have happened in untethered jailbreaks as it would have simply rebooted into the jailbreak mode)

i suggest you try these steps/and or look for other ways to enter DFU mode...as long as you can get into DFU mode you should be able to have your jailbreak software program reboot the ipad causing it to get out of its "stuck" state.

Hope this helps someone who has the same problem!

if you have trouble with getting into DFU mode (it can be tricky without doing it the way i do normally in itunes by holding the power button to shut it off ...as it was stuck and powering it off did not work) try to do a youtube search for other ways to put it into DFU mode will help!
Last edited:

Most reactions

Latest posts