What's new
Apple iPad Forum 🍎

Welcome to the Apple iPad Forum, your one stop source for all things iPad. Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Camera Roll photos don't delete iOS5


iPF Noob
Nov 1, 2011
Reaction score
I got some photos in from a friend and saved them into iPhoto. They went into the camera roll section. But now when I want to delete them, I can't. Is this a problem with iOS 5? I just picked up my iPad 2 a week ago.

With the listings of albums, I hit the "Edit" button to delete the camera roll album, but it is not highlighted. I'm assuming Apple doesn't want you to delete this album.

So I try to delete the individual photos from camera roll. Hit the arrow button on the right, click on the selected photos(s) and hit delete and then confirm to delete photo or all selected. I do it, it deletes it and then it returns. I thought because it was Halloween last night it was like the zombie from hell that wouldn't die.

Haven't synced with iTunes. Any solutions?? Thanks.
I would try and sync with itunes and then delete them in itunes. I personally had this issue when certain saved albums from itunes showed no delete key in an individual pic on the ipad. Strage though where you say there was a delete bucket icon and after you delete a pic it comes back. If you have backed up to the cloud you have to turn the cloud off first under settings before you can sync with itunes. I'm no expert with the iPad either. Just giving you what I had to do to delete pics or albums off the iPad.
I think it has to do with certain pic formats that I could not delete. itunes gave me more control but it is not that user friendly in my opinion.
Also search through the threads as these types of questions have been asked and answered many times. But I have not seen the pics reappearing one yet.
There is also an ios5 user guide:
Last edited:
Well, thanks for the suggestion, but I turned the unit this morning and tried to delete them again and now they actually delete. ???? Earlier, I would delete them and the picture would pop back in. Why it's doing it now, I have no clue.
Ah, welcome to the mystery of the iPad. I was going to tell you to restart the iPad (where you "slide to power off") in order to see if that would help you fix your problem with deleting.

Looks as if you discovered that trick works - accidentally. In other words, sometimes the iPad needs to be rebooted (for lack of a better word) to get it to work properly. Nothing biggy, it's what happens with computers.

Just glad that it's all working out for you now.


P.S. And, welcome to the forum! Hope you enjoy your visit(s).
Weird thing is I DID do a restart the other day and tried to delete and it still didn't work. That's when I began my search for an answer on the web that brought me to these forums. I let it sit on the shelve overnight and the next time I went into iPhoto, I was able to delete them. So the mystery is still unsolved. I have a feeling it is with iOS5, but that's only a guess. At least it works now.

Most reactions

Latest posts