What's new
Apple iPad Forum

Welcome to the Apple iPad Forum, your one stop source for all things iPad. Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Air video on different network?

DarkLordEnron

iPF Noob
Joined
Jul 25, 2010
Messages
121
Reaction score
0
Location
Va
Here's my question. If I'm at a Sparmuck's Coffee chain, and I want to connect and watch a video on my home server on its own private network is that possible with air video? It seems like it should be, but i don't know how the whole firewall situation would work out.
Or how about if my girlfriend wanted to access the server through her iPhone from her house while on her home network.. Would that be possible using the same settings I use at home for the app?

Anyone have experience with this? I've just never thought to use it away from home before for some weird reason. If I could stream a movie at her house from my server to my iPad and display it through the video accessory with my iPad to her HDTV?? Well, i think I would just be pretty damn happy at that point!

Might hit Starluck's tomorrow to test it out..
 
Last edited:

muyoso

iPF Noob
Joined
Jul 6, 2010
Messages
203
Reaction score
1
The Air video server has an option for Remote viewing. You enable this and it gives you a 9 digit or so code if I remember correctly. You input this code on the iPad and it works fairly well.
 
OP
D

DarkLordEnron

iPF Noob
Joined
Jul 25, 2010
Messages
121
Reaction score
0
Location
Va
When I hit "Test Connection", it gives me a popup dialog that says "Your AirVideo Server Instance is NOT accessible from internet." Any Idea as to what i need to do to make it work?
 

HaxEJxuK

iPF Noob
Joined
Aug 9, 2010
Messages
12
Reaction score
0
I believe you have to do port forwarding by accessing your router. I can't remember what the port number is but it should be listed in server or at least at Air video site. And when you do over the web, make sure you set password too.
 

pallentx

iPF Novice
Joined
May 28, 2010
Messages
663
Reaction score
5
Location
Fort Worth, TX
If your router support uPnP, it will automatically create the route. If not, you have to do something like this where the IP address points to the computer on your network that is running the airvideo server. Ignore the mstsc.exe line

portforward.jpg
 
OP
D

DarkLordEnron

iPF Noob
Joined
Jul 25, 2010
Messages
121
Reaction score
0
Location
Va
I believe you have to do port forwarding by accessing your router. I can't remember what the port number is but it should be listed in server or at least at Air video site. And when you do over the web, make sure you set password too.

Well it appears that my verizon router doesn't support UPnP! So that's likely why, I've forwarded ports, added exemptions and added the route. I've also enabled universal plug and play, although it seems to do nothing. Man, this is so disappointing! I guess I'll have to spring for a nice wireless N router in the near future..
 
Last edited:

HaxEJxuK

iPF Noob
Joined
Aug 9, 2010
Messages
12
Reaction score
0
You forwarded correct port to ip of your Airvideo server and it's still not working? Maybe you have firewall that's blocking it?

I believe you have to do port forwarding by accessing your router. I can't remember what the port number is but it should be listed in server or at least at Air video site. And when you do over the web, make sure you set password too.

Well it appears that my verizon router doesn't support UPnP! So that's likely why, I've forwarded ports, added exemptions and added the route. I've also enabled universal plug and play, although it seems to do nothing. Man, this is so disappointing! I guess I'll have to spring for a nice wireless N router in the near future..
 
OP
D

DarkLordEnron

iPF Noob
Joined
Jul 25, 2010
Messages
121
Reaction score
0
Location
Va
Well, I added the port to forward to the ip and it's still not working. Then, I tried adding the service to my exempt list, also enabling upnp on the server pc and it still doesn't work, although I'm now prompted with a password when accessing it from my LAN on the iPad. So it kind of halfway works. My money is on the router not supporting the upnp standard, even though it says it does.
 
OP
D

DarkLordEnron

iPF Noob
Joined
Jul 25, 2010
Messages
121
Reaction score
0
Location
Va
Ok, it works now! One should NOT check the "automatically map port" checkbox if routing manually or if the router doesn't support the upnp protocol. They didn't make this clear, but it makes total sense.
 
Last edited:

HaxEJxuK

iPF Noob
Joined
Aug 9, 2010
Messages
12
Reaction score
0
I don't think it should matter as long as you have forwarded the port. I'll go home after work and check my router settings. can you post screenshot of port forwarding mean while?

P.S. minus whatever info you don't want to share in that screenshot?

Well, I added the port to forward to the ip and it's still not working. Then, I tried adding the service to my exempt list, also enabling upnp on the server pc and it still doesn't work, although I'm now prompted with a password when accessing it from my LAN on the iPad. So it kind of halfway works. My money is on the router not supporting the upnp standard, even though it says it does.
 
OP
D

DarkLordEnron

iPF Noob
Joined
Jul 25, 2010
Messages
121
Reaction score
0
Location
Va
Sure thing, I'll get right on that for ya and I'll include the correct settings for both the router port forwarding and AV server instance. When you're in IT, you sometimes have one of "those days". :D
 
Last edited:
OP
D

DarkLordEnron

iPF Noob
Joined
Jul 25, 2010
Messages
121
Reaction score
0
Location
Va
Here are the settings you should be using to get this to work correctly if you're on a simple LAN and your server computer is operating 24/7 (so you can access your media 24/7. Obviously, if your server isn't running, you can't access anything from it. 0.o)

1: make sure AirVideo has these settings already set up before forwarding your ports. Click on "Settings" to bring this pane up. (Your password can be anything, just so long as it's relatively secure. Try using at least 4 letters, one uppercase and one number at the minimum. Remember, anyone who knows your server's IP can potentially gain access to it if they know what they're doing.)

screenshot-1.jpg


2: Your port forwarding window should look like this once you've entered all the necissary information into your router. (Rightmost pane)


screenshot2.jpg


3: This is what your router should display once you've confirmed all the changes. Wait at least 10 minutes before trying to access your media as sometimes the router needs that time to apply the changes. Do not check the "Automatically map port" function in the server settings, as this won't let you connect to the server. The AirVideo site is confusing, telling you to check it, but it didn't work at all for me when I did it that way.

screenshot.jpg
 
Last edited:
OP
D

DarkLordEnron

iPF Noob
Joined
Jul 25, 2010
Messages
121
Reaction score
0
Location
Va
I'm heading to Sblarbluck's now to test out these settings, i'll report back from there and confirm if these settings work.
 
OP
D

DarkLordEnron

iPF Noob
Joined
Jul 25, 2010
Messages
121
Reaction score
0
Location
Va
Well, it works. I'm streaming Lord of the rings from a starlucks about 15 miles from home base. Connecting to your server may take a little while longer than expected, and your bandwidth is obviously limited by the establishments router and upspeed. But just let her buffer a bit and you're gold! I'm now thinking I could've gotten awaymwith the base iPad model and simply stream everything I need at a moments notice. Dropbox combined with airvideo and good reader...iPad can't get much better than these apps for me right now!
 

Most reactions

Latest posts

Top