1. Due to the recent site upgrade, the iPadForums (iPF) App will no longer work. The new iPadForums.net website has been designed from the ground up to work perfectly from any mobile, tablet, or desktop computer using the built in internet browser. Create a shortcut to iPadForums.net on your home screen by following these steps: Create an icon for iPadForums.net

Two email accounts. How to make sure Compose New Mail autofills email address

Discussion in 'iPad General Discussions' started by joemz, Oct 16, 2011.

  1. joemz
    Offline

    joemz iPF Noob

    Joined:
    Oct 16, 2011
    Messages:
    5
    Thanks Received:
    0
    Trophy Points:
    0
    Location:
    NJ
    Ratings:
    +0 / 0
    I have a an activesync Gmail and Outlook Exchange work account. Gmail is set as my default account

    Prior to IOS5 I'd go to create a new email, it would set gmail as the FROM address, and if I type Alan as the addressee it would try to resolve Alan from the Gmail address book, and if not the Outlook address book

    After the upgrade if I type Alan, it displays all Alans in my Outlook book, then in the Outlook Global (all Alans in the company), but does not display Alan's in Gmail


    If the default email program is gmail, why isn't the default contract list gmail?
  2. twerppoet
    Offline

    twerppoet iPad Legend

    Joined:
    Jan 8, 2011
    Messages:
    15,935
    Thanks Received:
    1,808
    Trophy Points:
    113
    Location:
    Walla Walla, WA
    Ratings:
    +1,915 / 1
    Ok, pure guesswork here.

    There is a new default account settings for Contacts as well. Make sure that it is set to your GMail account and see what happens.

    In the Mail app make sure you are viewing the All Inbox or the Gmail account, and see if what happens.
  3. joemz
    Offline

    joemz iPF Noob

    Joined:
    Oct 16, 2011
    Messages:
    5
    Thanks Received:
    0
    Trophy Points:
    0
    Location:
    NJ
    Ratings:
    +0 / 0
    Thanks, but neither helped I already had gmail contacts as the default. And even when I set Mail to look at only gmail it still pulls contacts from Outlook. Groan
  4. twerppoet
    Offline

    twerppoet iPad Legend

    Joined:
    Jan 8, 2011
    Messages:
    15,935
    Thanks Received:
    1,808
    Trophy Points:
    113
    Location:
    Walla Walla, WA
    Ratings:
    +1,915 / 1
    No good ideas then.

    If both the Outlook and GMail accounts are up to date, you could try deleting the accounts and adding them again. Be sure to open the Contacts app in between so that it purges the database and forces a new sync when you add it the account again. Normally I'd suggests just turing Contacts off and on, but since it involve the email a complete delete would probably work better.

    Also, if you have not restarted or reset the device recently, that's worth a try.


    Restart: Hold down the power button until the power off slider appears. Slide it off. When the iPad finishes shutting down, hold down the power button again until the Apple logo appears.

    and then a reset if that does not work.

    Reset: Hold down the power and home buttons until the Apple logo appears. The iPad will reboot. This usually takes a bit longer than a restart.
  5. joemz
    Offline

    joemz iPF Noob

    Joined:
    Oct 16, 2011
    Messages:
    5
    Thanks Received:
    0
    Trophy Points:
    0
    Location:
    NJ
    Ratings:
    +0 / 0
    Thanks Twerppoet, but nothing seems to help, and in fact is getting worse :)

    I deleted both my gmail and exchange account, and checked that there were no contacts remain. Then i rebooted, and added the two accounts back, and rebooted

    Now, I still get the outlook contacts being used in the TO:, but even odder is that even though I have the gmail account set up as the default, the FROM is the outlook account.

    Very bizarre
  6. twerppoet
    Offline

    twerppoet iPad Legend

    Joined:
    Jan 8, 2011
    Messages:
    15,935
    Thanks Received:
    1,808
    Trophy Points:
    113
    Location:
    Walla Walla, WA
    Ratings:
    +1,915 / 1
    If you are in one of the Outlook folders instead of the All Inbox or a GMail folder the outlook address will override the default. Actually you want this, since if you are looking specifically at Outlook mail you probably want to reply with that address.

    That's all I can think of. Sorry.
  7. joemz
    Offline

    joemz iPF Noob

    Joined:
    Oct 16, 2011
    Messages:
    5
    Thanks Received:
    0
    Trophy Points:
    0
    Location:
    NJ
    Ratings:
    +0 / 0
    What you replied makes perfect sense, but it's not behaving that way. Regardless of what the last address book is that i use it goes to Outlook to pick new addressees. I can get around the problem by using the + sign on the TO: line, and that opens my gmail account. But if i just start typing a name, it picks from Outlook. Frustrated that it didn't behave this way before 5.0, and the apple genius had no clue how to fix it
  8. twerppoet
    Offline

    twerppoet iPad Legend

    Joined:
    Jan 8, 2011
    Messages:
    15,935
    Thanks Received:
    1,808
    Trophy Points:
    113
    Location:
    Walla Walla, WA
    Ratings:
    +1,915 / 1
    Not the last address book you used, the email folder that you are currenlty looking at.

    If you tap the button at the top left of the email list (it usually says Mailboxes) you get a list of inboxes and accounts. You may have to tap it more than once if you are in a sub folder. If you are in any of the Outlook folders, inbox or account, the From Address will default to the Outlook address. If you are in the All Inbox folder, it will be the default email address from settings. And if you are in a GMail folder, it will be the GMail address.

    At least that is how it usually works.

    Still no idea why you're having problems with the To: address.
    Last edited: Oct 17, 2011
  9. joemz
    Offline

    joemz iPF Noob

    Joined:
    Oct 16, 2011
    Messages:
    5
    Thanks Received:
    0
    Trophy Points:
    0
    Location:
    NJ
    Ratings:
    +0 / 0
    A few more reboots and the TO: issue seems to be resolved

    I have no proof, but my gut tells me that my contact issue is related to Linked Contacts, and since I don't even know what they are, or what value they offer, nor how to 'unlink', i can't test out my theory
  10. twerppoet
    Offline

    twerppoet iPad Legend

    Joined:
    Jan 8, 2011
    Messages:
    15,935
    Thanks Received:
    1,808
    Trophy Points:
    113
    Location:
    Walla Walla, WA
    Ratings:
    +1,915 / 1
    Linked entries happens when you have two or more address books. Contacts automatically links names it believes are the same. You can unlink contacts by taping the Edit button then taping the Link button at the bottom of the Page to remove the unwanted contact. You can also add/link a new contact that is related. It does not delete the contact, just tells Contacts that this is not the same person/business at the other contact.

    When contacts are linked and you have the All Contacts option selected on the Groups page, then all information from all linked contacts are shown for that name.

    I have no idea if that will make any difference. I have very few linked contacts, because the second address book I have has very view entries.

Share This Page

Search tags for this page

create default email account on ipad

,

default mail sender ipad

,

how to make gmail default email on ipad

,

ipad default email address for contact

,

outlook remove orginal sender compose new mail

,

when i compose new email from ipad my default account changes