Safari Password Autofill

Discussion in 'iPad Air 2 Forum' started by Lpatrick, Oct 22, 2015.

  1. Lpatrick

    Lpatrick
    Expand Collapse
    iPF Novice

    Joined:
    Feb 20, 2011
    Messages:
    48
    Thanks Received:
    2
    Can't get this feature to work. What's the magic answer. Also, I'm always having to re-enter passwords. Privacy mode is and always is turned off. Am very frustrated.
     
  2. J. A.

    J. A.
    Expand Collapse
    Super Moderator
    Staff Member

    Joined:
    Nov 11, 2012
    Messages:
    18,406
    Thanks Received:
    10,667
    In Settings - Safari - AutoFill, enable "Names and Passwords", in case it isn't.

    Make sure you find all the login details in Settings - Safari - General - Passwords.
     
  3. Lpatrick

    Lpatrick
    Expand Collapse
    iPF Novice

    Joined:
    Feb 20, 2011
    Messages:
    48
    Thanks Received:
    2
    I have Autofill enabled. What other details are there to know? I could not find any other info.
     
  4. J. A.

    J. A.
    Expand Collapse
    Super Moderator
    Staff Member

    Joined:
    Nov 11, 2012
    Messages:
    18,406
    Thanks Received:
    10,667
    The login usernames and passwords that are saved for Safari. They can be found in Settings - Safari - General - Passwords.

    What did you select in Settings - Safari - Privacy & Security - Block Cookies? If it's "Always Block", change it to something different.
     
  5. Lpatrick

    Lpatrick
    Expand Collapse
    iPF Novice

    Joined:
    Feb 20, 2011
    Messages:
    48
    Thanks Received:
    2
    Was not set to "Always Block". Is set to "Always Allow". Still does not work.
     
  6. Lpatrick

    Lpatrick
    Expand Collapse
    iPF Novice

    Joined:
    Feb 20, 2011
    Messages:
    48
    Thanks Received:
    2
    SOLUTION FOUND! Discovered that I have to tap "Passwords" on the top right of the keyboard.
     
  7. twerppoet

    twerppoet
    Expand Collapse
    iPad Legend II

    Joined:
    Jan 8, 2011
    Messages:
    20,681
    Thanks Received:
    6,575
    A side issue, but:

    The safer, and almost always functional setting is "Allow From Current Website Only". This prevents (or should prevent) third party websites from plundering information that is stored by other websites; while letting the website you are on do what it needs to operate correctly.

    I've never encountered a website that needed "Always Allow", and wouldn't trust one if I did.

    And congratulations on solving your problem. :)
     
  8. Lpatrick

    Lpatrick
    Expand Collapse
    iPF Novice

    Joined:
    Feb 20, 2011
    Messages:
    48
    Thanks Received:
    2
    Thanks for the advice. Switching now.
     
  9. twerppoet

    twerppoet
    Expand Collapse
    iPad Legend II

    Joined:
    Jan 8, 2011
    Messages:
    20,681
    Thanks Received:
    6,575
    No problem.
     
  10. SwanseaMick

    SwanseaMick
    Expand Collapse
    iPF Novice

    Joined:
    Feb 13, 2012
    Messages:
    30
    Thanks Received:
    4
    Can I point out that Settings/General/Keyboard/Shortcut must also be enabled, else 'autofill password' does not appear on the popup keyboard.
     
    #10 SwanseaMick, Nov 27, 2015
    Last edited: Nov 27, 2015

Share This Page


Search tags for this page

autofill safara