Remembering IDs and Passwords

Discussion in 'iPad Air Forum' started by John V, Mar 16, 2014.

  1. John V

    John V
    Expand Collapse
    iPF Noob

    Joined:
    Mar 16, 2014
    Messages:
    4
    Thanks Received:
    1
    Hello,
    First time poster. I hope I'm posting this question in the right place!
    I'm a new iPad Air owner after having a first generation iPad for several years. I frequent a couple other hobby forums with very similar features and functions as this one.
    On this Air, I found that when I "X" off the sight, (without logging off) I must log back on with my ID & PW when I return. This is happening even though I've selected "Remember Me" on the logon screen. It's happening on this forum as well.
    My old iPad, which I keep handy, continues to keep me logged in, so I figure I've got something set wrong on the new iPad.
    Sorry, if this is an old question.
    Any help would be greatly appreciated.
    John
     
  2. ardchoille

    ardchoille
    Expand Collapse
    iPad Addict

    Joined:
    Apr 21, 2012
    Messages:
    1,420
    Thanks Received:
    391
    Check that the following is toggled "on": Settings > Safari > Passwords & AutoFill > Names and Passwords. That should prompt Safari to store website information in iCloud Keychain.
     
  3. J. A.

    J. A.
    Expand Collapse
    iPad Legend

    Joined:
    Nov 11, 2012
    Messages:
    15,325
    Thanks Received:
    6,416
    You'll have to enable iCloud Keychain if you want to store the information there.
    It will remember your user name and password and enter it when you login to a site stored in Passwords & Autofill.

    What did you choose in Settings - Safari - Block Cookies?
     
    #3 J. A., Mar 16, 2014
    Last edited: Mar 16, 2014
  4. ardchoille

    ardchoille
    Expand Collapse
    iPad Addict

    Joined:
    Apr 21, 2012
    Messages:
    1,420
    Thanks Received:
    391
    I've always felt that this was pure genius! No longer are we required the memorize the credentials for the myriad websites we visit. Third-party apps are great for keeping this information stored, but iCloud Keychain means we don't often need to leave Safari to open another app to find login credentials.

    Thank you, Apple!
     
  5. John V

    John V
    Expand Collapse
    iPF Noob

    Joined:
    Mar 16, 2014
    Messages:
    4
    Thanks Received:
    1
    Names and Passwords was set to ON
    Block Cookies has "From third parties and advertisers" checked.
     
  6. ardchoille

    ardchoille
    Expand Collapse
    iPad Addict

    Joined:
    Apr 21, 2012
    Messages:
    1,420
    Thanks Received:
    391
    Since the functioning is different between your iPad Air and your old iPad, you might benefit from going through the settings on both devices and find which settings are different. This might help bring the device settings into sync. Something has to be different here if the two devices are acting differently.

    And, keep in mind that blocking third-party cookies may impact the functionality of some websites - such as those which use the Disqus comment system (you won't be able to log in due to blocked 3rd party cookies).
     
    #6 ardchoille, Mar 16, 2014
    Last edited: Mar 16, 2014
  7. J. A.

    J. A.
    Expand Collapse
    iPad Legend

    Joined:
    Nov 11, 2012
    Messages:
    15,325
    Thanks Received:
    6,416
    What does your browser look like?
    This:


    image-2985787525.jpg

    Or this:


    image-1081385627.jpg

    The latter is Private Browsing. If this is enabled, Safari doesn’t remember the pages you visit, AutoFill information, and your open tabs aren’t stored in iCloud.
     
  8. ardchoille

    ardchoille
    Expand Collapse
    iPad Addict

    Joined:
    Apr 21, 2012
    Messages:
    1,420
    Thanks Received:
    391
    Oh, excellent point! I always forget about the private mode.
     
  9. John V

    John V
    Expand Collapse
    iPF Noob

    Joined:
    Mar 16, 2014
    Messages:
    4
    Thanks Received:
    1
    I hope I did this right...Safari > Do Not track...I turned it on.
    While I was stumbling around, I noticed in iCloud that Keychain was OFF.
    I still have the dark border across the top of the screen. Phooey.
     
  10. J. A.

    J. A.
    Expand Collapse
    iPad Legend

    Joined:
    Nov 11, 2012
    Messages:
    15,325
    Thanks Received:
    6,416
    This means you're in Private Browsing, and that's why you have to login every time.
    To turn it off, open a new tab and tap "Private" (bottom left), or tap the search/address bar. When the keyboard appears, "Private" is written at the top left of the keyboard. Tap it to end Private browsing.
     

Share This Page



Search tags for this page
contact info won't autofill on ipad air
,
how do you store ids and passwords on ipad air
,
ipad air autofill my wrong email address 2013
,

memorize password on ipad

,
remember passwords ipad air