Problem with sending a Reply

Discussion in 'Forum Rules, Help and Info' started by dune, Jul 18, 2013.

  1. dune
    Offline

    dune iPF Noob

    Joined:
    Jul 18, 2013
    Messages:
    9
    Thanks Received:
    4
    Trophy Points:
    0
    Ratings:
    +4 / 0
    Using the iPF application as a Noob, I tried to enter a reply to a question on iPad Development information. My reply included a URL (to the Apple developer web site). But when trying to send the reply, this app detected the URL, raised an alert panel saying I could only include URLs after having posted 3 replies earlier, and noting I could enter my reply by first removing the URL - I clicked OK to this alert; and then spinning forever displaying a Sending icon on an otherwise blank page. When I clicked Cancel button, this behavior stopped, but my reply was lost! This seems like a bug in the application.

    Are such bugs normally reported in a new thread like this? Or is there some better way to report bugs?
  2. scifan57
    Offline

    scifan57 Super Moderator Staff Member

    Joined:
    Dec 3, 2011
    Messages:
    20,127
    Thanks Received:
    2,142
    Trophy Points:
    113
    Location:
    Regina,Canada
    Ratings:
    +2,405 / 1
    What you experienced was not a bug, but a designed feature of iPad Forums. Try writing and posting your reply without the link to the Apple developer website. It should work.
  3. dune
    Offline

    dune iPF Noob

    Joined:
    Jul 18, 2013
    Messages:
    9
    Thanks Received:
    4
    Trophy Points:
    0
    Ratings:
    +4 / 0
    The "feature" then appears to be a bug, in that it forces me to retype my entire reply, to remove the URL reference. My reply was 4 paragraphs long. Why should I have to retype it. Why can't the application just redisplay the text I was trying to send, so I could edit it to remove the URL?
  4. scifan57
    Offline

    scifan57 Super Moderator Staff Member

    Joined:
    Dec 3, 2011
    Messages:
    20,127
    Thanks Received:
    2,142
    Trophy Points:
    113
    Location:
    Regina,Canada
    Ratings:
    +2,405 / 1
    To edit your post, tap and hold your finger on the screen. A magnifying glass will appear onscreen. While still holding your finger on the screen, move the blue cursor in the magnifying glass until it is at the end of the portion you wish to edit, then release your finger. You can then use the backspace key to delete the portion of text you wish to remove. Once your text is edited, you can tap the send button.


    image-770834193.jpg

    image-2629602282.jpg
    Last edited: Jul 18, 2013
  5. dune
    Offline

    dune iPF Noob

    Joined:
    Jul 18, 2013
    Messages:
    9
    Thanks Received:
    4
    Trophy Points:
    0
    Ratings:
    +4 / 0
    Once the alert panel was displayed, my original reply was off-screen. When I clicked OK in the alert panel, the screen was blank except for the ever-spinning Sending icon; my original reply was not on display then, either. So I clicked Cancel button (at top of screen) to get out of the ever-spinning Sending icon loop... and my original reply was still not on display, and therefore could not be edited. I was forced to start over again.

    So I guess the bug is that, when clicking OK in the alert panel, the code continued looping in the Sending loop (I waited 30 seconds or more), instead of redisplaying my reply for editing.

    Doesn't this seem like a bug to you?
  6. scifan57
    Offline

    scifan57 Super Moderator Staff Member

    Joined:
    Dec 3, 2011
    Messages:
    20,127
    Thanks Received:
    2,142
    Trophy Points:
    113
    Location:
    Regina,Canada
    Ratings:
    +2,405 / 1
    Have you tried deleting, then re-installing the app?
  7. Gabriel1
    Offline

    Gabriel1 Super Moderator Staff Member

    Joined:
    Mar 11, 2011
    Messages:
    17,132
    Thanks Received:
    746
    Trophy Points:
    0
    Location:
    Cranbrook, Kent, UK
    Ratings:
    +747 / 0
    We will let the tech folks here know but out of interest.....what version of iOS are you running and which model iPad do you have?

    The Archangel
  8. dune
    Offline

    dune iPF Noob

    Joined:
    Jul 18, 2013
    Messages:
    9
    Thanks Received:
    4
    Trophy Points:
    0
    Ratings:
    +4 / 0
    This is a test reply including a URL: http://developer.apple.com

    I am attempting a reply to this chain, after deleting and re-installing the iPF application. Let's see if the problem is reproducible.
  9. dune
    Offline

    dune iPF Noob

    Joined:
    Jul 18, 2013
    Messages:
    9
    Thanks Received:
    4
    Trophy Points:
    0
    Ratings:
    +4 / 0
    OK, that reply got entered without triggering the URL-by-Noob alert panel. I guess that is because I have now entered more than three transactions. So there is no way for me to attempt reproducing this problem.

    I am using the latest iOS version: 6.3.1 (10B329), on iPad with Retina Display.
  10. Gabriel1
    Offline

    Gabriel1 Super Moderator Staff Member

    Joined:
    Mar 11, 2011
    Messages:
    17,132
    Thanks Received:
    746
    Trophy Points:
    0
    Location:
    Cranbrook, Kent, UK
    Ratings:
    +747 / 0
    That is correct, you are above the limit (which is designed to catch out those pesky spammers!) of posts.

    The Archangel

Share This Page