no access to Calendars?!? PANIC!

Discussion in 'iPad General Discussions' started by fig4159, Mar 10, 2015.

  1. fig4159

    fig4159
    Expand Collapse
    iPF Noob

    Joined:
    Mar 9, 2015
    Messages:
    7
    Thanks Received:
    1
    I have two iPads on the same account, and I was working on them very late last night. Idk what I did, but this morning there's no data in my calendar!. So I press Calendars. There's nothing there except a message saying it doesn't have access to my calendars & fix it in privacy settings. But in my privacy settings, I don't see anything I can do! Could someone PLEASE!, tell me how to get my calendars back? Thanks in advance. It's an iPad Air 1st gen running 8.1.3

    Julie
     
  2. J. A.

    J. A.
    Expand Collapse
    Super Moderator
    Staff Member

    Joined:
    Nov 11, 2012
    Messages:
    18,474
    Thanks Received:
    10,771
    Welcome to iPF, Julie!

    It's possible that you enabled restrictions for your Calendar app.

    Go to Settings - General - Restrictions - Privacy - Calendars. Make sure "Allow Changes" is checkmarked.

    Then look at the account that you use for your calendar entries. Make sure the calendar is enabled there.
    Force close the Calendar app:
    Double tap the Home button to show the multitasking bar and slide the picture above the Calendar app icon towards the top of the screen.

    Open the app again afterwards. If you still can't see the events you added, tap "Calendar" at the bottom. This will show all the calendars you could use in the app. Make sure the one you need is checkmarked.

    Drag down the calendars to force them to refresh. The spinning wheel should appear:
    image.jpg
    Let it finish refreshing. If the events still don't appear, force close the app once more and take a look at it again.

    Hope that helps.
     
  3. fig4159

    fig4159
    Expand Collapse
    iPF Noob

    Joined:
    Mar 9, 2015
    Messages:
    7
    Thanks Received:
    1
    Thanks for responding. Unfortunately, there is no Privacy under Settings/General/Restrictions. Privacy, in IOS 8.1.3, is in its own category (Settings/Privacy). But I tried to keep going from there. I can go to Privacy, Calendars. But when I get there, this is the ONLY thing on the screen: "Applications that have requested access to your calendars will appear here", and as I said, it's otherwise blank. I haven't allowed any apps access to my calendars, becase I don't need them to.

    But you said, Accounts, which I couldn't find, so I went searching, and somewhere along the way, I fixed the problem. I hope it didn't happen again, because I still don't know what I did to mess it up OR fix it. But, my datas back, so I'm happy again.

    Thank you very much for trying to help. I guess all I needed was some sleep and a new perspective.

    Julie
     
  4. J. A.

    J. A.
    Expand Collapse
    Super Moderator
    Staff Member

    Joined:
    Nov 11, 2012
    Messages:
    18,474
    Thanks Received:
    10,771
    I should have added a screenshot to show you what it looks like.
    There is Privacy in Settings - General - Restrictions. You have to scroll down to get there:
    image.jpg
    Maybe you need it sometime. :)

    However, I'm glad you got back your data. Hopefully this won't happen again. And I agree, sleeping over a problem sometimes helps solving it. :)
     
  5. fig4159

    fig4159
    Expand Collapse
    iPF Noob

    Joined:
    Mar 9, 2015
    Messages:
    7
    Thanks Received:
    1
    Idk what device or version if IOS you have, but it's not the same as I have. Even though my problem is fixed, I wanted to see if I'd missed something. I did not. I'm using an iPad Air, 1st generation, wifi only, with IOS 8.1.3. The screenshot you're showing is so completely different from top to bottom compared to mine, I've gotta know WHY. It's making me crazy. I hope you respond! I like mysteries, but I can't solve this one alone.

    Julie
     
  6. fig4159

    fig4159
    Expand Collapse
    iPF Noob

    Joined:
    Mar 9, 2015
    Messages:
    7
    Thanks Received:
    1
    BTW, here's what MY screenshot looks like, from Settings - General - Restrictions. Just to prove That I may be a noob, at least to Apple, but I'm NOT nutz. ;-)
     
    #6 fig4159, Mar 11, 2015
    Last edited by a moderator: Mar 12, 2015
  7. J. A.

    J. A.
    Expand Collapse
    Super Moderator
    Staff Member

    Joined:
    Nov 11, 2012
    Messages:
    18,474
    Thanks Received:
    10,771
    First of all, something very important:
    If you post a screenshot, do not show your iCloud ID. Use an app like Skitch to hide it, or crop the part where it's visible.

    The difference between our screenshots is: you've enabled restrictions, I didn't. And my iPad is in landscape mode. :)
    And here are my screenshots, to show you where Privacy is. You opened Restrictions, but didn't scroll down.
    Here's what we see when we open Restrictions:
    image.jpg
    And now, scrolling down:
    image.jpg
    Privacy appears. Scrolling further:
    image.jpg
    And once more:
    image.jpg
     
    #7 J. A., Mar 12, 2015
    Last edited: Mar 12, 2015
  8. scifan57

    scifan57
    Expand Collapse
    Administrator
    Staff Member

    Joined:
    Dec 3, 2011
    Messages:
    27,564
    Thanks Received:
    9,304
    I've deleted your screenshot as it included your full iCloud email address. You're welcome to repost the screenshot if you obscure the email address.
     
  9. fig4159

    fig4159
    Expand Collapse
    iPF Noob

    Joined:
    Mar 9, 2015
    Messages:
    7
    Thanks Received:
    1

    I didn't even think of it, but I didn't care anyway. If there's a rule against it, sorry about that!
     
  10. fig4159

    fig4159
    Expand Collapse
    iPF Noob

    Joined:
    Mar 9, 2015
    Messages:
    7
    Thanks Received:
    1

     

Share This Page


Search tags for this page

applications that have requested access to your calendars will appear here