1. Due to the recent site upgrade, the iPadForums (iPF) App will no longer work. The new iPadForums.net website has been designed from the ground up to work perfectly from any mobile, tablet, or desktop computer using the built in internet browser. Create a shortcut to iPadForums.net on your home screen by following these steps: Create an icon for iPadForums.net

Masks

Discussion in 'iPad Hacking' started by M4rk1ll3r, Aug 14, 2011.

  1. M4rk1ll3r
    Offline

    M4rk1ll3r iPF Novice

    Joined:
    Jul 16, 2011
    Messages:
    13
    Thanks Received:
    0
    Trophy Points:
    0
    Location:
    NZ
    Ratings:
    +0 / 0
    I am having issues with this tweak, is has crashed my iPad2 every time I have tried to use it. I know it works on some devices as I have seen the you tubes etc but even if it is my only tweak installed it crashes.....any ideas does it need other apps/tweaks to work?

    I noticed that when I have tried it the main screen has icons spaced with blanks (or just space) and everything is frozen and only home button double tap works but selecting an icon causes a re-boot/load.

    Cheers
  2. Pocobear
    Offline

    Pocobear iPad Junkie

    Joined:
    Oct 26, 2010
    Messages:
    608
    Thanks Received:
    9
    Trophy Points:
    0
    Location:
    Virginia, usa
    Ratings:
    +9 / 0
    Try this, open Cydia and search for "Masks", tap on it, in the upper right hand corner you will see "Modify" instead of "Install", tap "Modify", tap "Uninstall", then reboot, go back to Cydia and re-install the app, this time, after it resprings or reboots and comes back up, Hold down the "Power" and "Home" button until you see the Apple icon, wait for it to reboot, it may take up to 3-5 mins. Hopefully, this will fix your problem.
  3. M4rk1ll3r
    Offline

    M4rk1ll3r iPF Novice

    Joined:
    Jul 16, 2011
    Messages:
    13
    Thanks Received:
    0
    Trophy Points:
    0
    Location:
    NZ
    Ratings:
    +0 / 0
    Hi Pocobear,

    Can't uninstall as Ipad2 3G crashes and only re-boots when I try to launch anything from the close apps bar (the only thing that works is the double tap to bring this up). So I have tried rebooting after installing another two times same thing and also on a vanilla machine with no 3rd party apps at all - same thing once I go past the unlock screen everything freezes except the stop apps bar.

    Only other thing is that the app icons on the springboard screen appear smaller than normal/stock and they are spread out as if I can fit seven across the screen. As I don't have shrink or any Icon tweaks this might require them as a pre-requisite hence the problems I am having unless anyone can confirm that this works as a standalone app on the Ipad2 3G?

    Not happy with this app so far but I really want it work! :mad:

    Cheers
  4. OUTL4W
    Offline

    OUTL4W iPad Addict

    Joined:
    Dec 30, 2010
    Messages:
    1,231
    Thanks Received:
    5
    Trophy Points:
    0
    Location:
    Gettysburg, Pa
    Ratings:
    +5 / 0
    I can't see how masks could be the culprit. I've been using it since jb. Sounds like you might have inadvertently installed an iPhone app/tweak.
  5. M4rk1ll3r
    Offline

    M4rk1ll3r iPF Novice

    Joined:
    Jul 16, 2011
    Messages:
    13
    Thanks Received:
    0
    Trophy Points:
    0
    Location:
    NZ
    Ratings:
    +0 / 0
    Hi outlaw are you saying that even though I restored to a vanilla 4.3.3 with just the base software no apps then went to JBME3.0 then Cydia and then only installed masks and it still failed that I could have some how installed another iPhone tweak along the way? I would have noticed :) while that didn't happen it obviously doesn't like something about my set up maybe cause it's 3G and the only funny things are the icons and spacing when I try the masks tweak. Makes me think that the app was written with other tweaks installed and the package might have files or routines from the other apps (un educated guess mind you). Are you confirming that this app runs fine standalone with nothing else installed?

    Are there different versions as they don't show up in Cydia and it says that the app/tweak is compatible with iPod, iPhone and iPad anyway, I may have to wait for an update.

    Cheers
  6. f4780y
    Offline

    f4780y Super Moderator Staff Member

    Joined:
    Sep 11, 2010
    Messages:
    7,109
    Thanks Received:
    634
    Trophy Points:
    113
    Location:
    Troon, Scotland
    Ratings:
    +634 / 0
    Which repo did you install masks from? That might give a clue as to why it is not working.
  7. M4rk1ll3r
    Offline

    M4rk1ll3r iPF Novice

    Joined:
    Jul 16, 2011
    Messages:
    13
    Thanks Received:
    0
    Trophy Points:
    0
    Location:
    NZ
    Ratings:
    +0 / 0
    Hi f4780y

    Got app/tweak via author Elias Limneos a BigBoss sponsored tweak and it is version 1.0.

    Is this the info you were after?

    Regards Mark.
  8. f4780y
    Offline

    f4780y Super Moderator Staff Member

    Joined:
    Sep 11, 2010
    Messages:
    7,109
    Thanks Received:
    634
    Trophy Points:
    113
    Location:
    Troon, Scotland
    Ratings:
    +634 / 0
    Yes, that's the current version from the legitimate source. Lots of folks have it working. Sure you didn't also install something else at the same time?

    If you switch to expert mode on the top right of the "installed" screen, does "Icon Support" show as installed?
    Last edited: Aug 16, 2011
  9. M4rk1ll3r
    Offline

    M4rk1ll3r iPF Novice

    Joined:
    Jul 16, 2011
    Messages:
    13
    Thanks Received:
    0
    Trophy Points:
    0
    Location:
    NZ
    Ratings:
    +0 / 0
    Yep I'm sure I didn't install anything else - trust me I'm not an IT noob just an iPad one :)

    On the first install I got the you need to activate via the Internet message reported elsewhere but at least everything else on the iPad worked however after a reboot the problems stated started happening. Since then the only difference has been with the vanilla attempt where the lock screen went back to the apple default mask from the bear claw that I tried to change it to on the first go however locked up after that.

    I just wonder if some residual files or configuration hangs around after restores etc does anyone have any thoughts on this? Is there a guarenteed way of completely flushing back to vanilla and factory fresh as I think I did do this by restore and choosing set up as new from iTunes.

    It does/did show as installed as the icon turns to modify if I'm following you correctly.
  10. f4780y
    Offline

    f4780y Super Moderator Staff Member

    Joined:
    Sep 11, 2010
    Messages:
    7,109
    Thanks Received:
    634
    Trophy Points:
    113
    Location:
    Troon, Scotland
    Ratings:
    +634 / 0
    A restore is a complete wipe and reinstall. Nothing can survive.

    You didn't answer my question about Icon Support? It's a separate package. Change to expert mode like I said and see if it is there.
    Last edited: Aug 16, 2011
  11. f4780y
    Offline

    f4780y Super Moderator Staff Member

    Joined:
    Sep 11, 2010
    Messages:
    7,109
    Thanks Received:
    634
    Trophy Points:
    113
    Location:
    Troon, Scotland
    Ratings:
    +634 / 0
    I"m not sure what else to suggest. You are using the legitimate paid version from BigBoss and with nothing else installed there should be no issues.

    It does work, as can be seen on my screenshot, which is iPad2.

    Attached Files:

  12. M4rk1ll3r
    Offline

    M4rk1ll3r iPF Novice

    Joined:
    Jul 16, 2011
    Messages:
    13
    Thanks Received:
    0
    Trophy Points:
    0
    Location:
    NZ
    Ratings:
    +0 / 0
    Ok went into expert mode and there is no "icon support" package showing only big boss icon set which looks like part of the Cydia default setup, is there anything I can do to get this installed manually?

    Although the Cydia home screen shows the right device ie iPad GSM I noticed that I have iPhone firmware /sbin installed could this be causing the wrong version of masks to come down or confuse the app maybe or is a standard package?

    Cheers Mark.
    Last edited: Aug 18, 2011
  13. M4rk1ll3r
    Offline

    M4rk1ll3r iPF Novice

    Joined:
    Jul 16, 2011
    Messages:
    13
    Thanks Received:
    0
    Trophy Points:
    0
    Location:
    NZ
    Ratings:
    +0 / 0
    Given that I don't have Icon Support installed it doesn't seem worth having another go at installing masks unless anyone has any suggestions or easy workarounds?

    Although I now know how to restore to 4.3.3 blindfolded and discovered expert mode in Cydia so not all bad :)

    Cheers and thanks for help so far.
  14. f4780y
    Offline

    f4780y Super Moderator Staff Member

    Joined:
    Sep 11, 2010
    Messages:
    7,109
    Thanks Received:
    634
    Trophy Points:
    113
    Location:
    Troon, Scotland
    Ratings:
    +634 / 0
    Packages without the correct dependencies set are usually cracked or pirated ones, hence my questioning. It seems very odd to me that the paid version of Masks would not have it's dependencies correctly set, but I am not in a position to check whether "Icons Support" is even required, and it is not beyond the realms of possibility that the developer made a mistake.

    To install it, go to the "Sources" tab, press the "Settings" button on the top left, and choose "Developer" from the menu that pops up. Then press "Done".

    Now switch to the "Search" tab and search for "Icon Support". Press enter and choose the Icon Support package from the list and install it.
    I suggest you then switch to the "Installed" tab, find Masks, select it, and press the "Modify" button in the top right. This will re-install Masks.

    Then REBOOT your iPad and hopefully that should fix it.
  15. OUTL4W
    Offline

    OUTL4W iPad Addict

    Joined:
    Dec 30, 2010
    Messages:
    1,231
    Thanks Received:
    5
    Trophy Points:
    0
    Location:
    Gettysburg, Pa
    Ratings:
    +5 / 0
    Just did a fresh restore...and when choosing masks from my "installable purchases" it only auto-installs mobile substrate & preferenceLoader along with masks. No icon support. After installing masks purchase.....ipad is locked in portrait and can't swipe right/left on springboard...with no icons on the dock. Same thing happening as op in 1st post. Only way to fix is to restore.

    Can I install icon support seperately? Or does it have other dependencies?
    Last edited: Aug 18, 2011
  16. f4780y
    Offline

    f4780y Super Moderator Staff Member

    Joined:
    Sep 11, 2010
    Messages:
    7,109
    Thanks Received:
    634
    Trophy Points:
    113
    Location:
    Troon, Scotland
    Ratings:
    +634 / 0
    Well there you go. I did say it wasn't beyond the realms of possibility that the developer got it wrong. Maybe worth dropping him a note to let him know...

    Yes, you can install it separately. I gave instructions above. Also, you could just install any other tweak which affects icons. They all need it...
  17. OUTL4W
    Offline

    OUTL4W iPad Addict

    Joined:
    Dec 30, 2010
    Messages:
    1,231
    Thanks Received:
    5
    Trophy Points:
    0
    Location:
    Gettysburg, Pa
    Ratings:
    +5 / 0
    Thank you! That did the trick...except now I get the "you need the internet to activate masks" deal even though it's 1 of my installable purchase's from cydia.
  18. M4rk1ll3r
    Offline

    M4rk1ll3r iPF Novice

    Joined:
    Jul 16, 2011
    Messages:
    13
    Thanks Received:
    0
    Trophy Points:
    0
    Location:
    NZ
    Ratings:
    +0 / 0
    I was beginning to think it was just me and that I got a dodgy hardware build or something.

    So after I installed the iconsupport package then masks I got the activate message which doesn't go away and when I reboot mine crashes again and needs a restore. The only thing in masks that works while waiting for activation is the lock screen background and SB background trying to change icons doesn't work and the activation message appears again and I start all over again.

    I installed iconoclasm and gridlock to see if that helped but still no joy, it must need something else :confused:

    Outlaw have you rebooted after the activation message and can you confirm if all is working ok?

    Cheers.
  19. OUTL4W
    Offline

    OUTL4W iPad Addict

    Joined:
    Dec 30, 2010
    Messages:
    1,231
    Thanks Received:
    5
    Trophy Points:
    0
    Location:
    Gettysburg, Pa
    Ratings:
    +5 / 0
    After restore and back in the lock screen open sbs settings and respring...see if that does the trick.
  20. M4rk1ll3r
    Offline

    M4rk1ll3r iPF Novice

    Joined:
    Jul 16, 2011
    Messages:
    13
    Thanks Received:
    0
    Trophy Points:
    0
    Location:
    NZ
    Ratings:
    +0 / 0
    Progress.....of sorts...:)

    First thanks Outlaw for the SBSettings tip means I don't have to restore when I try a reboot to get rid of the "activation to use Masks" message I can just re-start and and respring in the lock screen, restoring was getting old but this always just sets me back into the "activate to use Masks" message loop however....

    ...The Lock screen image works, the SB background image works and even the launch app image works :confused: the only thing that doesn't work are the icon images. When I turn this on it either just pops up the activation blah blah again. A reboot of any sorts mean I have to use the SBS tip to gain control again.

    Other things I have noticed are that when it is in "About to crash mode" IE after a reboot the lock screen pop up about "no sim installed" doesn't appear and when going into the SB screen the screen dims (as if a pop up is going to appear but never does) the icons change size (whatever size I had in the first place) and the contacts and maps icons are white :confused:

    Just to confirm I put my iPhone sim in to see if that made any difference it didn't.

    Do you know what you did to get rid of the activation message?

Share This Page

Search tags for this page

cydia big boss app masks

,

masks cydia crash

,

masks source iphone cydia

,

problems with masks tweak on respring