Jailbroken iPad 2: Cydia apps installed, but nothing works

Discussion in 'iPad Hacking' started by verbalj, Dec 28, 2011.

?

Are all your jailbreak apps on your jailbroken iPad 2 still working as advertised?

  1. Yes

    0 vote(s)
    0.0%
  2. No

    0 vote(s)
    0.0%
  1. verbalj
    Offline

    verbalj iPF Novice

    Joined:
    Jul 15, 2011
    Messages:
    64
    Thanks Received:
    1
    Trophy Points:
    0
    Location:
    NYC
    Ratings:
    +1 / 0
    I'll preface this by saying this has nothing to do with the A4 untethered jailbreak that was released. I didn't mistakenly attempt a jailbreak on my A5 device. In fact, I haven't even used the iPad 2 much since before the weekend (stupid holidays :)) started.

    Anyway, as odd as it may sound, the iPad is jailbroken. Cydia is installed. Cydia can be launched and apps can be installed. However, every Cydia app that is installed isn't working -- almost as if they're not installed on the device. It's like the iPad is in safe mode (and no, it's not in Safe Mode).

    Just as an example, Barrel, FolderEnhancer, and Lockinfo are all installed, yet none of these apps are working. No transition effects. No multiple folders within folders and no lockscreen information. After poking around, I noticed in the native Settings app, none of the Cydia apps are listed (I used to have a long list there).

    The last thing I remember doing was reading on Zite, I put it down and went out. When I came back home, I noticed the app crashed while it was refreshing its content and the screen went black for an extended period. I did a hard reset (power and home button) and when it came back, it was in the aforementioned state.

    Has anyone come across this? I'm hoping/thinking it's a stupid fix since there was no foul play here. Thanks!
  2. steelew
    Offline

    steelew iPF Noob

    Joined:
    Dec 28, 2011
    Messages:
    1
    Thanks Received:
    0
    Trophy Points:
    0
    Ratings:
    +0 / 0
    Same thing here except I updated mobile substrate and two others (that I can't remember) that had to do with updating cydia. Now I am stuck in safe mode even though nothing tells me I'm in safe mode and doesn't allow me to exit safe mode. I've tried changing settings in SBsettings to trigger a respring (which it did but I'm still in safe mode). Right now, I'm trying to figure out what else updated yesterday. Also my ipad was fine until I turned it off at the end of the night. It worked for hours after the update.
  3. verbalj
    Offline

    verbalj iPF Novice

    Joined:
    Jul 15, 2011
    Messages:
    64
    Thanks Received:
    1
    Trophy Points:
    0
    Location:
    NYC
    Ratings:
    +1 / 0
    There was a mobile substrate update listed in Cydia? I don't recall that, never mind doing it. For what it's worth, I definitely always update my apps, so if there was a mobile substrate update, then I did it.

    For me, SBSettings isn't on the spingboard, nor is it in Settings. The only way I can find it is by searching for it. Triggering a respring, like you, didn't help.

    At least I know I'm not the only one with this problem. Hopefully, someone can offer us some help!
  4. TheRambler
    Offline

    TheRambler Super Moderator Staff Member

    Joined:
    Jun 19, 2011
    Messages:
    3,074
    Thanks Received:
    123
    Trophy Points:
    63
    Location:
    Lancashire, England.
    Ratings:
    +124 / 0
    Don't worry, I'm with you guys, since the update in Cydia, all hell broke loose, it's still jail broken, just nothing showing up in settings. Very weird.

    I'll let you know if I find a solution!
  5. verbalj
    Offline

    verbalj iPF Novice

    Joined:
    Jul 15, 2011
    Messages:
    64
    Thanks Received:
    1
    Trophy Points:
    0
    Location:
    NYC
    Ratings:
    +1 / 0
    So it was a mobile substrate update in Cydia? Was there such an update for the iPhone? I don't recall either! :eek:
  6. TheRambler
    Offline

    TheRambler Super Moderator Staff Member

    Joined:
    Jun 19, 2011
    Messages:
    3,074
    Thanks Received:
    123
    Trophy Points:
    63
    Location:
    Lancashire, England.
    Ratings:
    +124 / 0
    I finally bit the bullet and followed f4780y's fantastic restore process, I do this on a fairly regular basis as I find it keeps all the gaps filled from app deletion and the ipad running smoothly. See below for link..... PLEASE NOTE THIS SHOULD ONLY BE DONE IF YOU HAVE SAVED SHSH BLOBS FOR CURRENT J.B IOS

    http://www.ipadforums.net/jailbreak...-your-ipad-using-tinyumbrella-shsh-blobs.html

    I then resynced everything back on board. Its still going as yet, so I will pop back and let you know how I got on, I'm sure it will sort it, I will just check what updates from Cydia I get, if it happens again I will make note of the dodgy update that caused it and report back here.
    Remember just like everything in life, things can get glitchy and messy and problems occur, but its not a problem as long as you have your blobs saved!! Yes it takes a bit of time, but at least you get a nice spanky new Jailbreak and in some cases a faster and smoother running iPad!!

    Chris
  7. f4780y
    Offline

    f4780y Super Moderator Staff Member

    Joined:
    Sep 11, 2010
    Messages:
    7,109
    Thanks Received:
    635
    Trophy Points:
    113
    Location:
    Troon, Scotland
    Ratings:
    +635 / 0
    Note, there has been a new update to Mobile Substrate this morning. I suspect it resolves the issue some folks were having with JB apps not behaving as though the device was jailbroken.

    My iPad1 was doing something similar to the OP's post yesterday... Seems fine now I have applied the update.
  8. TheRambler
    Offline

    TheRambler Super Moderator Staff Member

    Joined:
    Jun 19, 2011
    Messages:
    3,074
    Thanks Received:
    123
    Trophy Points:
    63
    Location:
    Lancashire, England.
    Ratings:
    +124 / 0
    Trust me to go through all that when an update would be fine lol

    oh well. It feels like new again, plus I get to choose what I put back on it!

    Cheers for the update f4780y, hopefully its in time for the OP and others.
  9. verbalj
    Offline

    verbalj iPF Novice

    Joined:
    Jul 15, 2011
    Messages:
    64
    Thanks Received:
    1
    Trophy Points:
    0
    Location:
    NYC
    Ratings:
    +1 / 0
    Thanks for the replies and help everyone. I'm going to see if that mobile substrate update is available on my iPad. I did notice it on the iPhone (I didn't do it though, since I'm now scared lol). Of course, Cydia isn't refreshing. Whenever it does, and that update is available, I'll give it a shot. If that doesn't work, I'll just rejailbreak like Rambler suggested. Of course I have my SHSH blobs saved ;)

    I'll write back later with an update. Thanks again!
  10. TheRambler
    Offline

    TheRambler Super Moderator Staff Member

    Joined:
    Jun 19, 2011
    Messages:
    3,074
    Thanks Received:
    123
    Trophy Points:
    63
    Location:
    Lancashire, England.
    Ratings:
    +124 / 0
    It's a case of waiting for the refresh! Watch as it is happening and make sure it doesn't report any errors in the top left refresh pane whilst it goes through it's checks.

    It may take a day to finally calm down, but it's easier than rejailbreaking etc.
    Last edited: Dec 29, 2011
  11. verbalj
    Offline

    verbalj iPF Novice

    Joined:
    Jul 15, 2011
    Messages:
    64
    Thanks Received:
    1
    Trophy Points:
    0
    Location:
    NYC
    Ratings:
    +1 / 0
    Good tip! I'll try and remember that, especially since I'm not the most patient person in the world (god bless my girlfriend!) -- especially when it comes to electronics.
  12. verbalj
    Offline

    verbalj iPF Novice

    Joined:
    Jul 15, 2011
    Messages:
    64
    Thanks Received:
    1
    Trophy Points:
    0
    Location:
    NYC
    Ratings:
    +1 / 0
    Ah yes, now this is a thing of beauty!

    Attached Files:

Share This Page

Search tags for this page
cydia app not opening
,
cydia apps do not open
,
cydia apps do nothing
,

cydia apps installed but not working

,
cydia apps installed not working
,
cydia installed but not jailbroken
,
no cydia apps are working
,
no cydia apps working on ipad
,
none of my cydia apps are working
,

none of my cydia apps work

,

none of my jailbreak apps work

,
none of the apps from cydia are working on my iphone 3g
,
nothing from cydia works
,
nothing on cydia works
,
nothing working on cydia for iphone 5s 7.0.4
,
nothing works on ios 7 cydia
,
why am i on safe mode when there is nothing installed in clydia on i pad
,
why are no cydia packages working
,
why are none of my jailbreak stuff working
,

why do my cydia apps not open