iPad calendar has bug

Discussion in 'Forum Rules, Help and Info' started by davsan, Apr 17, 2014.

  1. davsan

    davsan
    Expand Collapse
    iPF Noob

    Joined:
    Apr 17, 2014
    Messages:
    4
    Thanks Received:
    0
    Since the last iOS update all the Australian holidays have appeared in my calendar on iPad and iPhone. The default alert is 2 days. I have changed the alert to None so many times and each time it reverts back to 2 days. There is no way it will keep the change.
     
  2. J. A.

    J. A.
    Expand Collapse
    Super Moderator
    Staff Member

    Joined:
    Nov 11, 2012
    Messages:
    17,405
    Thanks Received:
    9,316
    Hi, davsan! Welcome to iPF! Enjoy your time here!

    The Australian calendar (in your case) came with the last iOS update. It depends on your setup in Settings - General - International - Region Format. If you don't need it, you can disable it in the Calendar app.

    If you use a Google calendar (just as an example) as default calendar, like I do, but not the iCloud calendar, the default calendar alert settings on the iPad won't affect the alert times of the events. If you set up an event and change it to "None", you'll see that the alert time switches back to the time you chose for that calendar in Google settings, and this happens within seconds.

    What you'll have to do is to go to the account that you use as default calendar, through a browser, and edit the alert there. Then the changes will be used in the Calendar app as well, for every event you create. The events you created before changing the settings will still show the previous alert time. You'll have to go through all of them in your iPad Calendar app and change them manually, one by one.

    Hope that helps.
     
    #2 J. A., Apr 18, 2014
    Last edited: Apr 18, 2014
  3. davsan

    davsan
    Expand Collapse
    iPF Noob

    Joined:
    Apr 17, 2014
    Messages:
    4
    Thanks Received:
    0
    I use iCloud calendar. In Settings Default Alerts I have None for all-day events. In the calendar if I click on a holiday event it says alert 2 days before. When I click this & change to None it reverts back to 2 days even after saving. It is annoying getting alerts for holidays, so if I can't change I will have to disable Holidays.
     
  4. J. A.

    J. A.
    Expand Collapse
    Super Moderator
    Staff Member

    Joined:
    Nov 11, 2012
    Messages:
    17,405
    Thanks Received:
    9,316
    That's weird. If you already set all day events to "None", you shouldn't get alerts. Of course you can disable the events in the Calendar app. Or you could try the usual fixes. They might remove this glitch.

    Reset your iPad. This won't change settings, and data won't get lost. To do so press and hold Home and Power button simultaneously until the Apple logo appears. Release both and let the iPad power up.

    Force close the Calendar app:
    Double tap the Home button to reveal the multitask bar. Slide the picture above the Calendar app icon to the top of the screen.

    Restart your device:
    Turn it off, wait for a few minites and turn it on again.
     
  5. davsan

    davsan
    Expand Collapse
    iPF Noob

    Joined:
    Apr 17, 2014
    Messages:
    4
    Thanks Received:
    0
    I reset iPad & followed instructions but the problem still exists. So I have disabled the holidays, will keep track of them on paper calendar. Thanks for your help. It may be a glitch which needs addressing in next iOS update.
     
  6. J. A.

    J. A.
    Expand Collapse
    Super Moderator
    Staff Member

    Joined:
    Nov 11, 2012
    Messages:
    17,405
    Thanks Received:
    9,316

Share This Page



Search tags for this page

calendar bug on ipad

,
how to set ipad calendar to australian holidays
,
ipad calendar bugs
,
ipad calendar set australian holidays
,
why are my all day calendar alerts reverting from none