iPad 2 with AT&T says No Service after iOS7 update.

Discussion in 'iPad 2 Forum' started by cosrocket1, Nov 7, 2013.

  1. cosrocket1
    Offline

    cosrocket1 iPF Noob

    Joined:
    Nov 7, 2013
    Messages:
    7
    Thanks Received:
    0
    Trophy Points:
    0
    Ratings:
    +0 / 0
    I have an iPad 2 with AT&T cellular service which I have never activated. It used to say AT&T in the top left corner, but I disabled the cellular service under Settings because I would get popups asking me to create an AT&T account which I did not want to do. Anyway I recently upgraded the iPad to iOS 7 and noticed that it now says No Service in the top left corner, and that under settings the cellular setting is now enabled.

    So my question is, is there a problem, or did iOS 7 change what it says? Why did it say AT&T in iOS 6 but in iOS 7 it says No Service?

    I read to reset network settings and toggle the airplane mode but when I do that it searches for a moment and then goes back to No Service. I also took out the SIM card and put it back but no change.

    Any help is apreciated.
  2. J. A.
    Online

    J. A. iPad Legend

    Joined:
    Nov 11, 2012
    Messages:
    11,422
    Thanks Received:
    3,132
    Trophy Points:
    113
    Location:
    Apetlon, Austria
    Ratings:
    +3,774 / 3
    Hi, cosrocket1! Welcome to iPF!

    After updating, resetting the device is recommended: press and hold Home and Power button until the Apple logo appears, then release them and let the iPad start on it's own. It could help fixing some of your problems, like the one with your cellular service.

    If it doesn't help, try the following:
    Turn on Airplane Mode (Settings), wait for a few minutes, turn it off again.
    Go to Settings - General - Reset - Reset Network Settings. That's another kind of reset, and you will have to set up these settings again afterwards.

    Another idea: in Settings - Carrier: is there "Automatic" enabled?
    Last edited: Nov 7, 2013
  3. cosrocket1
    Offline

    cosrocket1 iPF Noob

    Joined:
    Nov 7, 2013
    Messages:
    7
    Thanks Received:
    0
    Trophy Points:
    0
    Ratings:
    +0 / 0
    Thanks for the welcome and your quick reply J.A!

    I tried them all and unfortunately it still says No Service. So i take it that means there is a problem, that even though I have not activated the cellular account on the iPad 2, it should still say AT&T as it did before I upgraded to iOS 7. Removing and replacing the SIM card doesn't help either. Under Carrier it says AT&T 15.5.

    Maybe I'l try leaving it on airplane mode longer and try it again. Thanks again!
  4. J. A.
    Online

    J. A. iPad Legend

    Joined:
    Nov 11, 2012
    Messages:
    11,422
    Thanks Received:
    3,132
    Trophy Points:
    113
    Location:
    Apetlon, Austria
    Ratings:
    +3,774 / 3
    When I disable cellular data on my iPad, it doesn't show the provider, it only shows "iPad" and the Wi-Fi signal. I know that it also was this way before I updated to iOS 7:


    image-2441379799.jpg
  5. cosrocket1
    Offline

    cosrocket1 iPF Noob

    Joined:
    Nov 7, 2013
    Messages:
    7
    Thanks Received:
    0
    Trophy Points:
    0
    Ratings:
    +0 / 0
    Yes, that's how it is. When I disable cellular it just says iPad, and when I enable cellular it says Searching for a moment and then No Service. I just don't know if iOS 7 has changed what it says from AT&T to No Service because the cellular service is not activated (yet turned on in settings), or if there is a problem.
  6. cosrocket1
    Offline

    cosrocket1 iPF Noob

    Joined:
    Nov 7, 2013
    Messages:
    7
    Thanks Received:
    0
    Trophy Points:
    0
    Ratings:
    +0 / 0
    I notice in your attachment it says APN Setting below Cellular Data. I do not see that on my iPad. Am I missing this setting?
    Last edited: Nov 7, 2013
  7. J. A.
    Online

    J. A. iPad Legend

    Joined:
    Nov 11, 2012
    Messages:
    11,422
    Thanks Received:
    3,132
    Trophy Points:
    113
    Location:
    Apetlon, Austria
    Ratings:
    +3,774 / 3
    It's the Access Point Name. My carrier allows editing, as I noticed. Maybe it's not permitted by your provider, that's why you don't see it.
  8. cosrocket1
    Offline

    cosrocket1 iPF Noob

    Joined:
    Nov 7, 2013
    Messages:
    7
    Thanks Received:
    0
    Trophy Points:
    0
    Ratings:
    +0 / 0
    You can see APN Settings is completely missing.

    image.jpg
  9. J. A.
    Online

    J. A. iPad Legend

    Joined:
    Nov 11, 2012
    Messages:
    11,422
    Thanks Received:
    3,132
    Trophy Points:
    113
    Location:
    Apetlon, Austria
    Ratings:
    +3,774 / 3
    My explanation came the moment you posted your screenshot. See the post before yours.
    I noticed that you have Bluetooth enabled. Do you use/need it? What happens when you turn it off?
  10. cosrocket1
    Offline

    cosrocket1 iPF Noob

    Joined:
    Nov 7, 2013
    Messages:
    7
    Thanks Received:
    0
    Trophy Points:
    0
    Ratings:
    +0 / 0
    Unfortunately there is no change when I disable Bluetooth. It still says No Service, as you can see in this screen shot.

    image.jpg
  11. J. A.
    Online

    J. A. iPad Legend

    Joined:
    Nov 11, 2012
    Messages:
    11,422
    Thanks Received:
    3,132
    Trophy Points:
    113
    Location:
    Apetlon, Austria
    Ratings:
    +3,774 / 3
    I read this somewhere else, but because I never turned off my iPad's cellular data, I can't remember if this was possible on an ipad in iOS 6. Perhaps you know: was there the option to turn off 3G, and if it was so, did you do this? That could be the reason that your device shows "No Service" now, in iOS 7.
  12. cosrocket1
    Offline

    cosrocket1 iPF Noob

    Joined:
    Nov 7, 2013
    Messages:
    7
    Thanks Received:
    0
    Trophy Points:
    0
    Ratings:
    +0 / 0
    Yes, I did turn off the 3G in iOS 6 because I would sometimes get a message that I should buy a cellular plan which I didn't want to do. So turning off the 3G got rid of the messages. The think is in iOS 6 if I turned 3G on then it would say AT&T in the top corner, instead of No Service as it says now.
  13. J. A.
    Online

    J. A. iPad Legend

    Joined:
    Nov 11, 2012
    Messages:
    11,422
    Thanks Received:
    3,132
    Trophy Points:
    113
    Location:
    Apetlon, Austria
    Ratings:
    +3,774 / 3
    Then this is the reason for "No Service" now. If it was turned off when you updated, there's no way now to turn it on again. I think you'll have to contact your carrier, if you don't want to see this the whole time. Or turn off Cellular and never enable it again.

Share This Page

Search tags for this page
att problems with ipad 2 ios update
,
i updated ipad to 8 now 3g says no service
,
ipad 2 shows no service
,
ipad no service
,
ipad no service at&t
,

ipad says no service

,
ipad shows no service
,
ipad2 att no service after ios8 update
,
ipad2 no service
,

my ipad says no service

,
my ipad says no service what do i do
,
no service in my ipad
,
no service message cellular data after ios 5 update
,

no service on ipad

,
no sim ios 7 ipad 2
,
since update ipad shows no service
,
why am i getting a nomservice message on my ipad
,
why does ipad say no service
,
why is my ipad showing no service
,
why my ipad shows at&t on top left corner