Ipad 2 5.0.1 recover options

Discussion in 'iPad Hacking' started by idunder, Oct 2, 2012.

  1. idunder
    Offline

    idunder iPF Noob

    Joined:
    Oct 2, 2012
    Messages:
    2
    Thanks Received:
    0
    Trophy Points:
    0
    Ratings:
    +0 / 0
    Hi, was wondering if someone can help me out here, I have looked through the forums and I believe I get how this works but just need confirmation..

    I Bought iPad 2, came with 5.0.1 installed on it.

    Ran Tiny Umbrella and the only SHSH blob available for it at the time was 5.1, so it downloaded that and I have it.

    Fast forward 4 or so months and I re-run Tiny umbrella and 6.0 is available now so it downloads the blobs for 6.0. (I should have gotten the 5.1.1 blobs, but never did..)

    So my Ipad 2 has 5.0.1 installed on it, and I have the SHSH blobs for 5.1 and 6.0.

    Recently I installed an update to an app in Cydia that would cause Springboard to wig out - Icons would spread out, keyboard would only be on one side of screen, screen corruption show up on the display. I can remove the app and respring or reload and then everything is back to normal. If I install other apps in Cydia the problem can come back, so it seems as if something has gotten corrupted somewhere somehow.

    I really need XBMC on this Ipad so I need to keep it jailbroken, do I not have ANY way to revert back to stock and start over again? (and hope I don't corrupt things again somehow)

    I can't do a system restore to the version of ios that is already on it right since i DON'T have the SHSH blobs? (5.0.1) I could then re-jailbreak it if I can revert to 5.0.1

    I just want to make sure I understand this.

    From my understanding my only option is to wait to see if an Ipad 2 Jailbreak comes out for 5.1 or 6.0 since those are the only SHSH blobs I have right?

    The part I don't get is why there is no way to pull something out of the currently running 5.0.1 I have to enable me to revert back to a virgin 5.0.1 image on the iPad 2.

    Thanks for any help!
  2. scifan57
    Offline

    scifan57 Super Moderator Staff Member

    Joined:
    Dec 3, 2011
    Messages:
    20,241
    Thanks Received:
    2,220
    Trophy Points:
    113
    Location:
    Regina,Canada
    Ratings:
    +2,521 / 1
    I'm afraid that if you remove your jailbreak and restore your iPad to stock you will end up on iOS 6. You would then have to wait for an iOS 6 jailbreak.
  3. f4780y
    Offline

    f4780y Super Moderator Staff Member

    Joined:
    Sep 11, 2010
    Messages:
    7,109
    Thanks Received:
    635
    Trophy Points:
    113
    Location:
    Troon, Scotland
    Ratings:
    +635 / 0
    Your combination of not having a full set of blobs and not being on a firmware for which you also have saved blobs is your problem, and unfortunately there is no way round it at the moment, or in the works as far as we know.

    Redsn0w will shortly be updated with a re-restore feature, allowing you to restore the version of IOS you currently have installed, but ONLY if you have blobs for that version. You don't.

    It will offer additional flexibility to upgrade / downgrade if you also have 4.x blobs, but again you don't.

    So as has already been said above, your only option is stabilise and live with your current installation, or move to 6.0 without a jailbreak until one is released.

    Consider using Cydia's "Expert" setting to see packages which are normally hidden. There could be something in there that was installed by your badly behaving tweak which should also be removed to stabilise your device. If you let us know what the tweak was we can check what else it installs for you. Details help! :D

    You just have to trust us that you cannot "extract" stuff out of what is installed. You need a bootrom exploit to do that, and there isn't one for the iPad2. Just because we can jailbreak these devices it does not mean that suddenly all their security is worthless. If that was the case, blobs would not be an issue and we would have compete freedom to do what we like whenever we want. That is simply not the case :(
    Last edited: Oct 3, 2012
  4. idunder
    Offline

    idunder iPF Noob

    Joined:
    Oct 2, 2012
    Messages:
    2
    Thanks Received:
    0
    Trophy Points:
    0
    Ratings:
    +0 / 0
    Thanks for the thorough explanation, now that I understand that the exploitation has not given access at the boot rom level it makes sense to why it is currently not possible to pull items out of the configuration that would allow a same ios rev rebuild and why you require the shsh blobs.

    If I would have only grabbed the 5.1.1 blobs while it was working fine.. darn. Well now I will always make sure every month to run tiny umbrella just in case.

    We just bought another new iPad 2 the other day and I guess we are in the same boat with that one and should tread carefully. It came with 5.1.1 (which was exploitable) but only 6.0 blobs are retrievable.

    I will go over things with a fine tooth comb with Cydia and see if I missed something that is causing the springboard instability.

    And I now have 6.0 blobs for both my devices so I will hope for a 6.0 jailbreak eventually that will be re-restore capable at some point with what I have now for 6.0.

    It's definitely better to buy one of these is at the moment a currently exploitable ios is available.

Share This Page