iOS 5 Safari Question

Discussion in 'iPad Help' started by Munky, Oct 14, 2011.

  1. Munky

    Munky iPad Enthusiast

    Joined:
    Aug 30, 2010
    Messages:
    343
    Thanks Received:
    4
    Trophy Points:
    0
    Location:
    Indiana
    Ratings:
    +4 / 0
    Irst of all I'm really loving Safari for ios 5 so much better and faster with tabbed browsing. My only problem, is that when I'm typing something to search for in the google bar, it only searches find on page. For example, when I type "disable find on page in safari iOS 5" it doesn't google it, it tries to find it on the page. Is there any way to disable find on page?
     
  2. twerppoet

    twerppoet iPad Legend

    Joined:
    Jan 8, 2011
    Messages:
    17,216
    Thanks Received:
    2,449
    Trophy Points:
    113
    Location:
    Walla Walla, WA
    Ratings:
    +2,981 / 1
    Weird. Have you tried the usual, close the app, restart, and reset?

    Other things I would try, if the above failed.

    Go to Safai in Settings and clear the cache and history, then go to the Advanced settings, Website Data, and clear out any mention of google.com or the entire thing.

    You could also try temporarily switching to one of the other search engines.


    All in all, it sounds like you aren't getting the Google search at all, wich is why you only get the local results.
     
  3. Munky

    Munky iPad Enthusiast

    Joined:
    Aug 30, 2010
    Messages:
    343
    Thanks Received:
    4
    Trophy Points:
    0
    Location:
    Indiana
    Ratings:
    +4 / 0
    I did all of the above with no luck. I can start out typing something and it will show search suggestions, then it will switch to find on page only.
     
  4. twerppoet

    twerppoet iPad Legend

    Joined:
    Jan 8, 2011
    Messages:
    17,216
    Thanks Received:
    2,449
    Trophy Points:
    113
    Location:
    Walla Walla, WA
    Ratings:
    +2,981 / 1
    Ok, I'm stumped.

    Does it do the same thing if you switch search engines? Yahoo? Bing?
     
  5. Munky

    Munky iPad Enthusiast

    Joined:
    Aug 30, 2010
    Messages:
    343
    Thanks Received:
    4
    Trophy Points:
    0
    Location:
    Indiana
    Ratings:
    +4 / 0
    Yes, still does the same thing. Can anyone else on iOS 5 confirm this behavior?
     
  6. twerppoet

    twerppoet iPad Legend

    Joined:
    Jan 8, 2011
    Messages:
    17,216
    Thanks Received:
    2,449
    Trophy Points:
    113
    Location:
    Walla Walla, WA
    Ratings:
    +2,981 / 1
    I have iOS 5, and it works fine. I should have mentioned that.
     
  7. Munky

    Munky iPad Enthusiast

    Joined:
    Aug 30, 2010
    Messages:
    343
    Thanks Received:
    4
    Trophy Points:
    0
    Location:
    Indiana
    Ratings:
    +4 / 0
    Have you tried typing " disable find on page in safari" to see if it does it?
     
  8. twerppoet

    twerppoet iPad Legend

    Joined:
    Jan 8, 2011
    Messages:
    17,216
    Thanks Received:
    2,449
    Trophy Points:
    113
    Location:
    Walla Walla, WA
    Ratings:
    +2,981 / 1
    Ok, I think I see what is happening. Correct me if I'm wrong, please. :)

    You're typing until all the Google suggestions disappear and the only think left is the On The Page options. If you select/touch that, of course it only searches on the page. But have you tried just tapping the Search button on the touch keyboard instead? When I do (using your example) it goes to the google search just as expected.
     
    • Like Like x 1
  9. Milliebert

    Milliebert iPad Fan

    Joined:
    Aug 5, 2011
    Messages:
    165
    Thanks Received:
    16
    Trophy Points:
    0
    Location:
    England
    Ratings:
    +16 / 0
    I just tried what twerppoet said, I get the same thing. You just hit search on the keypad and it'll do the Google search properly.
     
  10. Munky

    Munky iPad Enthusiast

    Joined:
    Aug 30, 2010
    Messages:
    343
    Thanks Received:
    4
    Trophy Points:
    0
    Location:
    Indiana
    Ratings:
    +4 / 0
    You're right. It does search properly. It was just weird that no more google suggestions came up and the find on page box was at the bottom above the keyboard.
     
  11. twerppoet

    twerppoet iPad Legend

    Joined:
    Jan 8, 2011
    Messages:
    17,216
    Thanks Received:
    2,449
    Trophy Points:
    113
    Location:
    Walla Walla, WA
    Ratings:
    +2,981 / 1
    Good, because I had no idea what to suggest next if that wasn't the answer. :)
     
  12. Munky

    Munky iPad Enthusiast

    Joined:
    Aug 30, 2010
    Messages:
    343
    Thanks Received:
    4
    Trophy Points:
    0
    Location:
    Indiana
    Ratings:
    +4 / 0
    It was just an odd behavior. I rarely used safari before iOS 5 and don't remember it ever doing that before. Thanks for the help though! :)
     
  13. twerppoet

    twerppoet iPad Legend

    Joined:
    Jan 8, 2011
    Messages:
    17,216
    Thanks Received:
    2,449
    Trophy Points:
    113
    Location:
    Walla Walla, WA
    Ratings:
    +2,981 / 1
    No problem.

    I just tried your long search in Safari on the iMac. It does the same thing, only it's not as obvious because the remaining list is Recent searches, and not On This Page. I bet other browsers to the same thing. After all there has to be a limit to how many suggestions vs. search queries Google keeps handy. If you type long enough you're bound to run it against it's limits.
     
Similar Threads
  1. danielb
    Replies:
    2
    Views:
    1,475
  2. BobHelms
    Replies:
    7
    Views:
    12,380
  3. Heaviside
    Replies:
    10
    Views:
    5,821
  4. iFrog
    Replies:
    6
    Views:
    2,100
  5. Timey
    Replies:
    3
    Views:
    2,044
Loading...

Share This Page

Search tags for this page
bing top hits
,
how to turn off safari msn search suggestion on ipad
,

how to turn off suggestions in safari on ipad

,
problem with suggestions for bing search on ipad
,

turn off google suggestions in safari

,

turn off google suggestions safari ipad

,
turn off search engine question in safari
,

turn off search suggestions bing ios

,
turn off search suggestions in safari
,
turn off search suggestions in safari on ipad