Help with iPad Numbers needed

Discussion in 'iPad Help' started by colineve, Jan 14, 2014.

  1. colineve

    colineve
    Expand Collapse
    iPF Noob

    Joined:
    Oct 19, 2012
    Messages:
    7
    Thanks Received:
    0
    I have just downloaded Numbers for iPad and wish to duplicate a spreadsheet from my iMac numbers. If I do this through iCloud I cannot encrypt with a password and if I turn off iCloud to copy across it doesn't show . Question one is how do I copy across if iCloud is turned off and question two is when I set a password for the app itself it stays active until and when I reboot, surely this should not stay active when I come out off and revisit and should ask for the password again.
     
  2. The OB

    The OB
    Expand Collapse
    Super Moderator
    Staff Member

    Joined:
    Aug 10, 2012
    Messages:
    4,618
    Thanks Received:
    1,643
    G'day colin and welcome to the forum. It was necessary to delete your identical post in the UK Forum as it was a duplication of the above post in the Help forum here. Kindly do not duplicate posts as it potentially fragments the conversation and may be confusing to members as to which post to respond to. There are helpful members here who will likely respond to your issue soon.
    Thanks and enjoy the forum
    Andrew


    Sent from Oz using Tapatalk
     
  3. twerppoet

    twerppoet
    Expand Collapse
    iPad Legend II

    Joined:
    Jan 8, 2011
    Messages:
    20,286
    Thanks Received:
    5,820
    According to the Numbers Help file, you can't use Passwords with files stored in iCloud.

    I would have also said the iOS's version of Numbers did not support passwords, but I check just to make sure, and I was wrong. So I learned something today. Thanks. :)

    To bypass iCloud you have several options.

    The first, and easiest if you're only going to to this occasionally, is to email the file to yourself. When you view the email in Mail on the iPad, tap and hold on the attachment. You will get an option to Open it in Numbers. Because it is password protected, it won't just open. Number will open to the files view instead, where you will have to select the spreadsheet then provide the password before you open it.

    Another option is to use a cloud service like DropBox. With the DropBox app installed on both the iPad and computer. You copy or move the file to the DropBox folder on the computer, wait a small while for it to sync, then go to the DropBox app on the iPad. From there you an choose to Open In Numbers. I suspect (because I have not tested this one) that it will behave similarly to opening it from the Mail app.

    If you need other options, or more detailed instructions, just ask.
     
  4. colineve

    colineve
    Expand Collapse
    iPF Noob

    Joined:
    Oct 19, 2012
    Messages:
    7
    Thanks Received:
    0

    My apologise for posting twice, I was not sure my first post had registered,

    Colin
     
  5. colineve

    colineve
    Expand Collapse
    iPF Noob

    Joined:
    Oct 19, 2012
    Messages:
    7
    Thanks Received:
    0
    Thanks for your time twerppoet. I can sort of get over the iCloud problem on my Mac by temporary removing the password on my spreadsheet and then passing it over to iCloud and once it's in there I can reinstate the password on the comp. It does mean that if I make alterations to the spreadsheet I have to redo that operation to update the iCloud version. This is ok.
    My main problem now is that on my iPad, I can opt to include a password on the spreadsheet and with iCloud disengaged, as it were, the only way I can get it to ask for the password is to completely shut down and reboot. If I leave the iPad open and I have opened numbers and shut it down to do other things when I open the app again it does not ask and just opens. Surely this should ask for the password every time you open the app. Thanks again, Colin
     
  6. twerppoet

    twerppoet
    Expand Collapse
    iPad Legend II

    Joined:
    Jan 8, 2011
    Messages:
    20,286
    Thanks Received:
    5,820
    When an app is closed with the Home button, it is frozen in RAM, not completely closed. This is usually an advantage, since it lets the app open quickly to it's last run state, allowing for quick switching between apps.

    In your case, however, the app starting where it left off means it starts with the last file open and already unlocked.

    I don't know of anyway to change this behavior in Numbers. I know it is possible, because I have apps that require unlocking every time they open, so it's most likely an oversight on Apple's part. Although it won't have any immediate affect, I recommend leaving some feedback with Apple. They are probably already aware of the issue, but the more feedback they receive the higher priority the issue should get.

    In the mean time it should not be necessary to restart to reset the locked state of the file, though it will require a few more steps.

    One option is to close the file before exiting Numbers. I haven't experimented, but unless you've turned on the Remember Password in the file's preferences it should require the password every time you open it from the file list. If it does not, then add that to your feedback.

    The other options is to clear the app from RAM. To do this double press the Home button to get the multitask bar, find the Numbers app, then swipe up on the thumbnail above the icon. This will remove the app from RAM and force a clean restart the next time it is opened

    Restarting the iPad does this for all apps; though it does not remove their icons from the multitask bar.


    Good luck.
     
  7. colineve

    colineve
    Expand Collapse
    iPF Noob

    Joined:
    Oct 19, 2012
    Messages:
    7
    Thanks Received:
    0
    Thanks a lot twerppoet, I have done what you suggested and sent a note to Apple but find what you say about clearing the ram after a session works fine , so I will go with that until they get their act together, thanks again,

    Colin
     
  8. twerppoet

    twerppoet
    Expand Collapse
    iPad Legend II

    Joined:
    Jan 8, 2011
    Messages:
    20,286
    Thanks Received:
    5,820
    No problem. Glad to help.
     
  9. twerppoet

    twerppoet
    Expand Collapse
    iPad Legend II

    Joined:
    Jan 8, 2011
    Messages:
    20,286
    Thanks Received:
    5,820
    All the iWorks apps just received an update. One of the new features is to share password protected documents via an iCloud link. While this isn't exactly what you were trying to do, it does suggest iCloud will now store protected documents.

    Anyway, I thought it might be worth your time to test it out and see if your issue is fixed.

    Make sure you download the update on both the iPad and Mac. I suspect you'll need both to make it work, if it works.

    Good luck.
     
  10. colineve

    colineve
    Expand Collapse
    iPF Noob

    Joined:
    Oct 19, 2012
    Messages:
    7
    Thanks Received:
    0

    Thanks again, will try

    Colin
     

Share This Page