Help, I'm stuck in safe mode.

Discussion in 'iPad Hacking' started by TylerThomas, Jul 20, 2012.

  1. TylerThomas

    TylerThomas iPad Fan

    Joined:
    Jul 2, 2012
    Messages:
    100
    Thanks Received:
    10
    Trophy Points:
    0
    Ratings:
    +10 / 0
    Hey,

    I got some thing I had ordered in the mail today. They were a few iPad accessories. One of them was a USB hub.

    I connected the USB hub with a camera connection kit and started reconnecting it with flash drives plugged into it to test it out. So I connected a 4GB flash drive with it and it mounted fine. Then I tried connecting a 4GB and a 2GB at the same time. they mounted fine, no problem. Then I tried connecting two 4GB drives and the 2Gb drive at the same time. This time I couldn't get them to mount. So I tried connecting just the two 4GB drives at the same time, and my iPad rebooted and went into safe mode.

    I unplugged the USB hub and tried rebooting and no luck I was still in safe mode. I tried rebooting again, and still no luck.

    So, I don't know what else to try at this point. It wasn't a software issue, whatever happened, so I can't just uninstall the offending program.

    What should I do?

    Please respond quickly, so I can straighten this out.

    Thanks.
     
  2. AllenSalar

    AllenSalar iPad Enthusiast

    Joined:
    Jul 13, 2012
    Messages:
    359
    Thanks Received:
    19
    Trophy Points:
    0
    Ratings:
    +19 / 0
    Uhm, try holding the Power and Home button simultaneously for like 15-30 seconds then release. See if it fixes that.
     
  3. TylerThomas

    TylerThomas iPad Fan

    Joined:
    Jul 2, 2012
    Messages:
    100
    Thanks Received:
    10
    Trophy Points:
    0
    Ratings:
    +10 / 0
    That didn't work either.
     
  4. TylerThomas

    TylerThomas iPad Fan

    Joined:
    Jul 2, 2012
    Messages:
    100
    Thanks Received:
    10
    Trophy Points:
    0
    Ratings:
    +10 / 0
    I assume I'm going to have to do an iTunes restore.
     
  5. AllenSalar

    AllenSalar iPad Enthusiast

    Joined:
    Jul 13, 2012
    Messages:
    359
    Thanks Received:
    19
    Trophy Points:
    0
    Ratings:
    +19 / 0
    Wait, is your iPad jailbroken?
     
  6. TylerThomas

    TylerThomas iPad Fan

    Joined:
    Jul 2, 2012
    Messages:
    100
    Thanks Received:
    10
    Trophy Points:
    0
    Ratings:
    +10 / 0
    Yes.
     
  7. TylerThomas

    TylerThomas iPad Fan

    Joined:
    Jul 2, 2012
    Messages:
    100
    Thanks Received:
    10
    Trophy Points:
    0
    Ratings:
    +10 / 0
    Do I need to do an iTunes restore? I'd really prefer I didn't have to.

    Does anyone know how to help me in this situation or should I go to jailbreakqa?
     
  8. Mickey330

    Mickey330 Administrator Staff Member

    Joined:
    Aug 30, 2010
    Messages:
    11,596
    Thanks Received:
    1,840
    Trophy Points:
    113
    Location:
    Western NY state (USA)
    Ratings:
    +2,017 / 0
    What app or tweak were you using to mount those flash drives? That may be what's hung up. Try uninstalling that app or tweak and see if that helps you get out of Safe Mode.

    Marilyn
     
  9. Gabriel1

    Gabriel1 Super Moderator Staff Member

    Joined:
    Mar 11, 2011
    Messages:
    17,098
    Thanks Received:
    747
    Trophy Points:
    0
    Location:
    Cranbrook, Kent, UK
    Ratings:
    +749 / 0
    That will be why the question is posted in the hacking section.......

    The Archangel
     
  10. TylerThomas

    TylerThomas iPad Fan

    Joined:
    Jul 2, 2012
    Messages:
    100
    Thanks Received:
    10
    Trophy Points:
    0
    Ratings:
    +10 / 0
    @Marilyn:

    I tried that already :-(

    I was using iFile and USB Mounting Toggle Switch. Like I said I thought maybe that would solve the problem too, so I removed both of them and rebooted, but to no avail.

    I don't know what else to do! I really really don't want to do an iTunes restore, because I have some files on here that I don't want to loose, but I already tried transferring them to an external storage device and iFile wouldn't load.
     
  11. Mickey330

    Mickey330 Administrator Staff Member

    Joined:
    Aug 30, 2010
    Messages:
    11,596
    Thanks Received:
    1,840
    Trophy Points:
    113
    Location:
    Western NY state (USA)
    Ratings:
    +2,017 / 0
    Have you tried going back to Cydia and reinstalling iFile? Once you uninstalled it/rebooted the iPad, maybe try again with the Cydia install? Did you use Cydia to UNinstall iFile? Sometimes, if you take it off yourself, without going through Cydia, you cause more problems for yourself. Hopefully, using Cydia to put it back on may re-load it right.

    Honestly, that's all I can think of. And, I think it is iFile that's messing you up. So, unfortunately, unless you can get iFile to "behave," I'm afraid you are facing a restore.

    Sorry, but I'm all out of options.

    Marilyn
     
  12. TylerThomas

    TylerThomas iPad Fan

    Joined:
    Jul 2, 2012
    Messages:
    100
    Thanks Received:
    10
    Trophy Points:
    0
    Ratings:
    +10 / 0
    Hey Marilyn,

    I figured it out. It wasn't iFile or USB toggle switch, it was Bigify+. I had had a safe mode problem with the Bigify+ package once before too.

    For reference I went into SBSettings and went to Mobile Substrate Add-Ons and disabled everything then resprung. This took my iPad out of safe mode. Then I just had to isolate which package was causing the problem. So I figured out it was Bigify+ and removed it in Cydia. Now everything is back to normal.

    It might just be the package itself or might be because I use Shrink too and they conflict with each other, but either way there is an issue there that I have experienced twice now. I wasn't using it for anything permanent anyway, so it's ok I had to remove it.

    But no, I removed iFile in Cydia when I tried that. I didn't do it myself. I've reinstalled it since then, and like I said everything is back to working order.

    Thanks for trying to help.
     
    • Like Like x 1
  13. Mickey330

    Mickey330 Administrator Staff Member

    Joined:
    Aug 30, 2010
    Messages:
    11,596
    Thanks Received:
    1,840
    Trophy Points:
    113
    Location:
    Western NY state (USA)
    Ratings:
    +2,017 / 0
    Whew! Glad you got it fixed.

    And yeah, I wouldn't run two tweaks together that do essentially the same thing (Shrink and Bigafy). Good pick on Shrink - that's one of my faves. :)

    And, thanks for highlighting the technique of disabling the Mobile Substrate items to figure out what was wrong. Not only is that a reminder to me for any other trouble-shooting problem (to ensure I recommend that), but it also may help someone else coming along with a Safe Mode problem. So, appreciate it.

    Again, yay!

    Marilyn
     
  14. yof

    yof iPad Fan

    Joined:
    Mar 23, 2012
    Messages:
    162
    Thanks Received:
    16
    Trophy Points:
    0
    Location:
    EST
    Ratings:
    +16 / 0
    Hey man that's very good news that you solved it! Good info!

    And that's even more exciting to see a USB Hub expansion for memory especially the games you talked about!
     
  15. TylerThomas

    TylerThomas iPad Fan

    Joined:
    Jul 2, 2012
    Messages:
    100
    Thanks Received:
    10
    Trophy Points:
    0
    Ratings:
    +10 / 0
    Yeah it's handier than having to uninstall and reinstall all of your packages, when you can just disable them with like effect.
     

Share This Page

Search tags for this page
bigify safemode issue
,
igotya stuck safe mode
,
ipad, exit safe mode
,

why my ipad exit saf mode