Duplicate mailboxes

Discussion in 'iPad Help' started by Mfnd, Oct 23, 2011.

  1. Mfnd

    Mfnd iPF Noob

    Joined:
    Sep 25, 2011
    Messages:
    8
    Thanks Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    Not sure if anyone else is getting this problem but I have 2 mail boxes appearing in mail on my iPad1 (Ios5). One is for my dot mac account and the ther for my iCloud account. Both are the same account but it means I get all emails twice which is mildly annoying!

    Anyone know how to stop this? In my settings it says mail settings are with iCloud, infact the exact same settings as on my iPhone, but that only displays the iCloud account.

    Have tried turning the mail off in the iTunes sync on my computer but then I loose both mail accounts.

    Any help greatly appreciated!

    Cheers in advance.
     
  2. richsadams

    richsadams iPad Super Guru

    Joined:
    Mar 23, 2011
    Messages:
    3,500
    Thanks Received:
    99
    Trophy Points:
    0
    Location:
    NW Left Coast
    Ratings:
    +99 / 0
    Moved to iPF Help area where you're likely to get a better response to your question.
     
  3. twerppoet

    twerppoet iPad Legend

    Joined:
    Jan 8, 2011
    Messages:
    17,278
    Thanks Received:
    2,470
    Trophy Points:
    113
    Location:
    Walla Walla, WA
    Ratings:
    +3,024 / 1
    This is a guess, because I'm not certain from your description what you are doing:

    Turn off your mail syncing in iTunes. This is not where you want to sync mail from.


    On you iPad (with an internet connection), go into Settings > Mail, Contacts, Calendars, and Add Account. Choose iCloud and enter your information. If this account is already present, try deleting and re-adding it. This is the only place you should have your iPad set for mail syncing. If you still have your old MobileMe @me.com account, delete it also. (provided you've already migrated it to iCloud)
     
  4. Mfnd

    Mfnd iPF Noob

    Joined:
    Sep 25, 2011
    Messages:
    8
    Thanks Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    Thanks for the reply. I am not syncing mail through iTunes, that is turned off and the only account which displays in the mail tab of settings in my iPad is iCloud, but I still get a mail box for .mac and one for iCloud. Have tried removing and the re-installing the account but still get both boxes.
     
  5. twerppoet

    twerppoet iPad Legend

    Joined:
    Jan 8, 2011
    Messages:
    17,278
    Thanks Received:
    2,470
    Trophy Points:
    113
    Location:
    Walla Walla, WA
    Ratings:
    +3,024 / 1
    Strange. Let me ask a few questions to make sure I understand.

    When you are looking at the Mailboxes list you see two (at least) entries under Inboxes, one of iCloud and another named .mac? Do you have the All Inboxes choice?

    Are you also getting two entries under the Accounts list. The iCloud account will show up as your Apple ID/email address? There should be one entry here for each account, just like the Inbox options. Unlike the Inboxes, you can get to all your synced folders by choosing the account.

    If you select All Inboxes, do you get duplicate emails as well?
     

    Attached Files:

  6. Mfnd

    Mfnd iPF Noob

    Joined:
    Sep 25, 2011
    Messages:
    8
    Thanks Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    Hi

    That is exactly what I get-just as described/pictured. If I click on all inboxes then I get all mails in folders as they all appear twice. If I select just the iCloud account inbox then I only get them once but the badge stays on the home screen for 10mins or so to say I have unread mail as this is in the .mac folder. I have to press the refresh icon a few times after a minute or so to update the other account that the mail has been read.

    In settings the only mail account it lists is iCloud where it lists all the other iCloud functions I am using on the iPad (calendars etc).

    As I say, I have exactly the same settings on my iPhone and this only shows my iCloud account and works fine.

    Cheers.
     
  7. twerppoet

    twerppoet iPad Legend

    Joined:
    Jan 8, 2011
    Messages:
    17,278
    Thanks Received:
    2,470
    Trophy Points:
    113
    Location:
    Walla Walla, WA
    Ratings:
    +3,024 / 1
    I think I understand what it happening.

    I just noticed that there are two places on the iPad that you can set up iCloud. One is in Settings > Mail, Contacts, Calendars > Add Account. The other is Settings > iCloud.

    Delete the account in the first one. Then make sure you are signed in with the iCloud settings themselves, and Mail is turned on. At that point the iCloud settings will show up in the Mail, Contacts, Calendars settings again, but there will be no delete option when you open it.
     
  8. twerppoet

    twerppoet iPad Legend

    Joined:
    Jan 8, 2011
    Messages:
    17,278
    Thanks Received:
    2,470
    Trophy Points:
    113
    Location:
    Walla Walla, WA
    Ratings:
    +3,024 / 1
    After further though, I might have got the sequence wrong.

    Go to the iCloud settings and delete those. Then go to the Mail account settings, and if there is an iCloud account, delete it. Then go back to the iCloud settings and sign back in.

    Hopefully one of these will work for you.
     
  9. Mfnd

    Mfnd iPF Noob

    Joined:
    Sep 25, 2011
    Messages:
    8
    Thanks Received:
    0
    Trophy Points:
    1
    Ratings:
    +0 / 0
    Many thanks for that-issue solved!

    Thanks again for the help.
     
  10. twerppoet

    twerppoet iPad Legend

    Joined:
    Jan 8, 2011
    Messages:
    17,278
    Thanks Received:
    2,470
    Trophy Points:
    113
    Location:
    Walla Walla, WA
    Ratings:
    +3,024 / 1
    No problem. Glad it worked. :)
     

Share This Page

Search tags for this page
i have duplicate folders in my email iphone
,

ipad duplicate accounts in mail

,
on all mail why do i have duplication of mail
,
why does my ipad have two identical icloud accounts
,
why does my iphone get duplicate emails