Changing Google Region in iPad

Discussion in 'iPad 2 Forum' started by ScorpionBlues, Nov 18, 2011.

  1. ScorpionBlues
    Offline

    ScorpionBlues iPF Novice

    Joined:
    Oct 11, 2011
    Messages:
    19
    Thanks Received:
    0
    Trophy Points:
    0
    Ratings:
    +0 / 0
    Hi,
    I have recently bought a iPad from Hong Kong on my visit, and now I m back to my country United Arab Emirates.
    whenever I try using google search on the new iPad it takes me to Google.com.hk :\ .
    How can I change it to google.com
  2. richsadams
    Offline

    richsadams iPad Super Guru

    Joined:
    Mar 23, 2011
    Messages:
    3,500
    Thanks Received:
    99
    Trophy Points:
    0
    Location:
    NW Left Coast
    Ratings:
    +99 / 0
    Try flushing Safari's cache.

    Settings > Clear History/Clear Cookies and Data

    Also:

    Settings > Safari > Advanced > Remove All Website Data

    That should give you a clean slate. However Google relies on IP addresses for default location so depending on your ISP's IP it may not automatically return the location you want. In that case you can physically type in http://www.google.ae/ for example and then bookmark it.

    If you need to change your iPad's region:

    Settings > General > International > Region Format

    Hope that helps!
    Last edited: Nov 18, 2011
  3. ScorpionBlues
    Offline

    ScorpionBlues iPF Novice

    Joined:
    Oct 11, 2011
    Messages:
    19
    Thanks Received:
    0
    Trophy Points:
    0
    Ratings:
    +0 / 0
    Sorry didn't worked :(
  4. richsadams
    Offline

    richsadams iPad Super Guru

    Joined:
    Mar 23, 2011
    Messages:
    3,500
    Thanks Received:
    99
    Trophy Points:
    0
    Location:
    NW Left Coast
    Ratings:
    +99 / 0
    You're saying you can't type http://www.google.ae/ (or whichever Google location/country you want) and it won't come up so you can bookmark it...it returns the UK version? If so I'm stumped.
  5. Sjakiez
    Offline

    Sjakiez iPF Noob

    Joined:
    Jan 20, 2012
    Messages:
    1
    Thanks Received:
    0
    Trophy Points:
    0
    Ratings:
    +0 / 0
    Hi scorpionplus, did you manage to solve it? I have the same issue, if you use the google search on the right top site it will always go to .hk (in Chinese!) what I don't want
    @richadams: yes I can manually type a new address every time but obviously that is cumbersome and would like it by default to search in google.nl in my case
    So if anyone knows a solution?
  6. nazr1e
    Offline

    nazr1e iPF Noob

    Joined:
    Jun 23, 2012
    Messages:
    1
    Thanks Received:
    0
    Trophy Points:
    0
    Location:
    malaysia
    Ratings:
    +0 / 0
    hi there have you guys discovered the solution? what i did was, I change the REGION FORMAT in settings. First, go to SETTINGS --->GENERAL-->INTERNATIONAL-->REGION FORMAT (this is where you select your desired country). Well it works for me. -new iPad, iOS 5.1.1-

Share This Page

Search tags for this page

google on ipad is hongkong

,

how to change google location on ipad

,
how to change ipad google search location
,
ipad google location
,
ipad google search wrong country