advice please

Discussion in 'iPad Hacking' started by samch, Jul 2, 2011.

  1. samch
    Offline

    samch iPF Novice

    Joined:
    Mar 16, 2011
    Messages:
    59
    Thanks Received:
    1
    Trophy Points:
    0
    Location:
    plymouth uk
    Ratings:
    +1 / 0
    Hi , I understand this is the ipad forum but figured the principles are the same for the iphone. i have just jb my iphone 4 for the first time i'm on ios 4.3.3 and my husbands 3gs but what happens when the new ios 5 comes out , I understand it may not be able to be jb straight away so my question is can I just update it as normal ?(knowing I will lose the jb ) or do I restore and update ?
    or is there anything special I have to do instead ? can you please provide a link to the relevant thread for me please if there is. I tried to install tiny umbrella to save my shsh bobs but it said it's not compatible with windows 7 64 bit and I have not seen the make my life easier button on cydia althought at the top it says shsh ios 4.3.3 .
    I read the information about shsh blobs but I'm not 100% sure if I only need them if I keep the same ios till a new jb version is out rather than update straight away.
    please advise as I want to be set sooner rather than too late and end up with mobiles i can't update.
    sorry if this has been asked before i did search, guess i should have asked before i jb ;)
    thanks in advance
  2. samch
    Offline

    samch iPF Novice

    Joined:
    Mar 16, 2011
    Messages:
    59
    Thanks Received:
    1
    Trophy Points:
    0
    Location:
    plymouth uk
    Ratings:
    +1 / 0
    someone please :)
    I am enjoying having a jb phone more than I thought I would so will be doing my ipad if I can get a answer to my question :ipad-back:
  3. Crazyjackson
    Offline

    Crazyjackson iPF Novice

    Joined:
    May 1, 2011
    Messages:
    57
    Thanks Received:
    0
    Trophy Points:
    0
    Location:
    Washington
    Ratings:
    +0 / 0
    When it comes out you can just update, I don't believe you need to restore.

    But of course you'll lose the jailbreak
  4. graywolf
    Offline

    graywolf iPad Super Guru

    Joined:
    Aug 22, 2010
    Messages:
    3,655
    Thanks Received:
    35
    Trophy Points:
    0
    Location:
    Raleigh, NC USA
    Ratings:
    +35 / 0
    You cant update a jailbroken device. You have to restore to stock using DFU mode first, then upadate and re-jailbreak.
  5. f4780y
    Online

    f4780y Super Moderator Staff Member

    Joined:
    Sep 11, 2010
    Messages:
    7,109
    Thanks Received:
    635
    Trophy Points:
    113
    Location:
    Troon, Scotland
    Ratings:
    +635 / 0
    Hi. You are right the process is pretty much the same.

    Since I am assuming you will want to preserve your jailbreak, applications, settings, and data, I suggest you look at my guide here:

    http://www.ipadforums.net/jailbreak...des/26399-how-upgrade-your-ios-jailbreak.html

    This is a process you can follow to preserve all those things. It will be the same for IOS5, however you will of course have to wait until a jailbreak is released for iOS5 BEFORE you start!

    Hope that helps.
    Last edited: Jul 2, 2011
  6. samch
    Offline

    samch iPF Novice

    Joined:
    Mar 16, 2011
    Messages:
    59
    Thanks Received:
    1
    Trophy Points:
    0
    Location:
    plymouth uk
    Ratings:
    +1 / 0
    thanks to all of you for all your help.
    Last edited: Jul 2, 2011
  7. f4780y
    Online

    f4780y Super Moderator Staff Member

    Joined:
    Sep 11, 2010
    Messages:
    7,109
    Thanks Received:
    635
    Trophy Points:
    113
    Location:
    Troon, Scotland
    Ratings:
    +635 / 0
    I don't know why you think it is not compatible. I only run W7 64 and it has always worked. It does however need java to be installed.
  8. samch
    Offline

    samch iPF Novice

    Joined:
    Mar 16, 2011
    Messages:
    59
    Thanks Received:
    1
    Trophy Points:
    0
    Location:
    plymouth uk
    Ratings:
    +1 / 0
    i reinstalled java and tried to install tiny umbrella yet again, now it says it's not a valid win 34 bit application then stops ( I know I'm a 64 bit but it still says that so I'm stumped, there's no other version to download) , i'm downloading it from the main website so don't know what i'm doing wrong and i'm not acccidently using the osx version or anything lol
    Last edited: Jul 4, 2011

Share This Page

Search tags for this page

tinyumbrella not a valid win32 application